Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to switch into Unicode entry mode using Ctrl + Shift + U, but after I hit this combination nothing happens. I also tried Ctrl + U, Ctrl + Alt + U. Do I need to enable this mode anywhere? Or maybe it works only in certain places? I use default USA layout.

share|improve this question
    
What application are you trying it in? –  Chipaca Dec 20 '10 at 13:13
    
@Chipaca I tried in several: Firefox. Terminal, gedit... none of them works –  Nutel Dec 21 '10 at 3:08
add comment

3 Answers 3

up vote 3 down vote accepted

This feature works in all gtk+-based applications when they use the default gtk+ input method. For example, all GNOME applications, OpenOffice.org and Firefox.

However, if you have enabled IBus in order to write complex scripts, then you lose the Ctrl+Shift+U facility. You would need to disable IBus and return bug to the gtk+ input method.

share|improve this answer
add comment

It's a GNOME feature, and it should work for all GNOME applications.

share|improve this answer
    
I see, seems that something is broken my OS... –  Nutel Dec 20 '10 at 2:49
add comment

You get very little feedback when you do this, but, when you hit Ctrl+Shift+U you should get an underlined u. You then enter the unicode codepoint, followed by space or enter; until you hit space or enter you'll only see the underlined u followed by the codepoint as you entered it; when you hit space or enter the whole thing is replaced by the unicode character.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.