Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I want music (played e.g. via Audacious) to be played on speaker system, and all other sounds produced by other applications (including ubuntu sound effects) to be played on headphones.

  1. My computer has sound connectors at its back, and also connectors on its front panel. When I connect both headphones and speakers, only headphones work (I take it, the front connectors take precedence?). Should I purchase another sound card (in addition to the motherboard-integrated sound I have)?

  2. When I go to Audacious output settings, I see only the ouput plugin selection list, with PulseAudio selected and options like ALSA, OSS4 etc. But there's no facility to select particular output device (and I guess it wouldn't magically appear even if I had the second soundcard). Is this at all possible to bind specific application to particular output device?

share|improve this question
    
Maybe pavucontrol could help? Type 'pavucontrol' on a terminal window ou 'sudo apt-get install pavucontrol' to install it. –  desert_unbound Mar 9 at 18:25
    
I've already given this up, but thanks for the suggestion. I'll give it a try should I ever come back to this. –  Mike Mar 10 at 19:26

1 Answer 1

up vote 1 down vote accepted

Two ways to do this: one is less specific to an application, and more to a task, and almost certainly will work, the other has worked on and off, but is more application specific.

Method 1 (the surefire one): Note this is reliant on parts of KDE and may be desktop-specific. Open up Phonon audio settings and flip through the categories. Music can be assigned a different sound card than communications like Skype through a list which orders them from most preferred to least for each category. This may work on GNOME like desktops such as Unity, Xfce, LXDE, and other Gtk+ environments, but I have no proof.

Method 2 (partially covered in comments): If you are using KDE, again, you're all set. If you are using a Gtk or other desktop you may need to install something. In KDE, just open up Kmix and right-click on the application slider shown in that'll window. You should see an option to switch sound cards. With another desktop, install pavucontrol (shown as Pulse Audio Volume Control in the menu) flip to the applications tab, and either there's a button listing the sound card, or you right click on the app. Not 100% sure which, but the functionality is there (I think)

Being a Zoom H4n, Intel Audio, and M-Audio user, I know it can be done.

share|improve this answer
    
Thanks for the response. I had a look on pavucontrol and did not see a button to switch the sound card for specific application. Possibly because I have only one sound card (in pactl there's move-sink-input command which switches sinks for specific input stream, which seems what I want but again, sink = sound card and I have only one). –  Mike May 6 at 12:09
    
Did you try Kmix? If you have Vivid installed it won't even pull in KDE like with older versions (THANK YOU KDE5) –  JimmyC866 May 7 at 2:36
    
Just now. It works and there's grayed out "move" item in the right click menu for each app. So I guess my problem boils down to installing another sound card. I'm glad this issue is finally resolved, thank you. –  Mike May 8 at 11:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.