Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to get MySQL back on Ubuntu 12.04?

i'm getting the following error when trying to install MySQL Server under Ubuntu:

Setting up mysql-server-5.5 (5.5.22-0ubuntu1) ...
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing mysql-server-5.5 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.5; however:
 Package mysql-server-5.5 is not configured yet.
dpkg: error processing mysql-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error    from         a previous failure.
                          Errors were encountered while processing:
 mysql-server-5.5
 mysql-server
 E: Sub-process /usr/bin/dpkg returned an error code (1)

I've tried all kinds of solutions I had found on the web, but none of them works: I've tried apt-get purge mysql-server* mysql-common, I've deleted all directories, I've tried installing by apt-get install -f mysql-server, I checked dpkg -S and also dpkg --configure mysql-server-5.5

More info:

Kernel : 3.0.8+
Ubuntu 12.04 LTS
Hardware : MK802 ( a chip ARM )
login as root with password
share|improve this question

marked as duplicate by Jorge Castro, Alvar, hhlp, Ringtail, Eric Carvalho Jan 1 '13 at 2:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I try to reinstall mysql from a fresh unbuntu LTS 12.04 ... but i've got the same error ... –  user1017446 Aug 31 '12 at 13:53
add comment

1 Answer 1

Try downloading the .deb file from launchpad and install it.

share|improve this answer
    
ok, i try this and tell you if it's ok. –  user1017446 Aug 29 '12 at 8:03
    
It's i386 version you give me, have you the arm version ? –  user1017446 Aug 29 '12 at 9:32
    
    
I'm sorry, maybe i miss something ? But i'm on arm proc. so i386 doesn't work on my linux. On the website i don't find a mysql-server armel version. Can you confirm ? Pierre –  user1017446 Aug 29 '12 at 12:07
    
Check this link –  devav2 Aug 29 '12 at 12:17
show 2 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.