Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new Dell XPS 15z laptop and did a fresh install of 12.04 LTS on it. I've looked at several guides such as "How to enable hibernation in 12.04?" and "Dell XPS 15 L502X & Ubuntu 12.04 Linux", which says to first try running sudo pm-hibernate to see if it works before adding the Hibernate option to the system menu.

When running that command the screen switches to black, I see a little text cursor blink in the top left of the screen for a few seconds, then the system shuts off (as expected). When I power it up again, however, it starts up from scratch rather than resuming the suspended state. I have 7.7GB of RAM and 7.9GB of swap space, as was automatically set up during the Ubuntu installation.

Looking at the main Ubuntu wiki page for this hardware, it says "To hibernate, on Ubuntu 12.04, laptop should be certified, but it is working fine with this type of laptop, so if you like to activate hibernate function, you have just to create this file...", so because it works for others on this laptop I must be doing something wrong.

I followed the steps in that guide to put acpi=noirq into the default Grub options in order to fix booting problems. I haven't done the other steps for Bumblebee NVIDIA support, but when I tried it earlier it didn't help things. I have a new laptop and a fresh install of 12.04 LTS, so I'm willing to try anything to get hibernate working. Does anyone have ideas?

In case it's an issue with the swap space, here is the output of sudo fdisk -l. Could this problem have something to do with selecting the option of encrypting my home directory, which is asked on the Ubuntu installation screen? I see something about /dev/mapper/cryptswap1 below:

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0006a9e3

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048  1448589311   724293632   83  Linux
/dev/sda2      1448591358  1465147391     8278017    5  Extended
Partition 2 does not start on physical sector boundary.
/dev/sda5      1448591360  1465147391     8278016   82  Linux swap / Solaris

Disk /dev/mapper/cryptswap1: 8476 MB, 8476688384 bytes
255 heads, 63 sectors/track, 1030 cylinders, total 16556032 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xd09077d5
share|improve this question
    
Possibly this guide to install Tux on Ice could be solution for you: askubuntu.com/a/356289/58470 –  Dee Oct 10 '13 at 14:04

1 Answer 1

Your method is a bit complicated. I have got a simpler method :

To re-enable hibernation, hit Ctrl+Alt+T then type sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla.

Edit the file and add these lines

[Re-enable hibernation] Identity=unix-user:* Action=org.freedesktop.upower.hibernate ResultActive=yes**

Save the file. After this, restart your machine and upon login, you should see a hibernation option on the top right settings corner

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.