Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to compile freetds according to these instructions: http://www.mavrick.id.au/2012/php-5-3-6-mssql-freetds/

However configure is failing. My command is:

./configure --enable-msdblib -–prefix=/usr/local/freetds

I'm getting

configure: error: unrecognized option: `-–prefix=/usr/local/freetds'
Try `./configure --help' for more information.

for all command line options, even --help

I have build-essentials, gcc and make installed. I also tried sudo, even though I am logged in as root. It seems to me something is still missing?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You have to use --prefix ("minus minus"), not -–prefix ("minus dash")

share|improve this answer

You've copy-pasted the command from a webpage and, if you look closely, you've got a funny character instead of one of the dashes in --prefix.

Just type it in manually :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.