Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Syslog: on Pastebin

Every time I turn on my webcam and start the screen sharing my Ubuntu 12.04 (Unity 3D) logs out and show me the login screen. The syslog above shows the relevant lines. Does someone know any solution?

Btw: My skype version: Skype 4.0.0.8

share|improve this question
    
Does it also happen if you stop webcam before starting screen share? –  MestreLion Sep 19 '12 at 17:53
    
By the way, does screen share works if you don't start webcam at all? –  MestreLion Sep 19 '12 at 17:54
    
I see that it works here on my new notebook. Sorry. I think its because of the update. I will check it at my home computer if the problem still appears. –  Michael Tanner Sep 21 '12 at 8:04
add comment

2 Answers 2

Approaches I suggest you to try in your home computer:

Before starting skype:

  • Create another user in your computer, for test purposes. It will have a clean environment perfect for testing. This will rule out any broken settings in your account. Log in as this user, start skype, and see if it works.

  • Make sure your webcam is working fine, using annother application. I suggest cheese.. That will rule out any hardware issues. Also test the webcam using the test user you created.

  • Delete the ~/.Skype hidden folder in your user's home folder. It will reset your preferences, but it may also fix the bug.

Now start skype. It should probably work.

If not, please post any relevant logs and/or messages and I'll help you out.

Good luck :)

share|improve this answer
add comment

try to remove skype: sudo apt-get remove skype and remove user configuration files sudo rm /home/USERNAME/.Skype/ then reinstall skype sudo apt-get install skype

share|improve this answer
    
Could not reproduce the error again. Sorry. Now it seems to freeze Unity randomly when having webcam or screen sharing active. –  Michael Tanner Sep 26 '12 at 11:14
    
1. have you removed skype? 2. have you removed configuration files and changed the USERNAME into your actual username 3. have you reinstalled skype and reboot your ubuntu ? –  user91632 Sep 26 '12 at 11:23
    
try to get this software github.com/kapliars/doctor-skype –  user91632 Sep 26 '12 at 11:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.