Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've written:

/dev/sda2 /win ntfs-3g rw,dev,exec,auto,async,users,umask=777,uid=1000,gid=1000,locale=en_US.utf8,  errors=remount-ro 0 0

but I still can't access /win as a user (corresponding to uid/gid specified). As root I can access /win and can see that no permissions are set at all (I supposed umask=777 is meant to set all permissions).

share|improve this question
    
Why dev,exec,async? –  karthick87 Dec 19 '10 at 14:58
1  
@karthick87 exec because I want to be able to execute, dev and async because they are included in default and I don't know what's their actual impact is. –  Ivan Dec 19 '10 at 15:08
    
Try this /dev/sda2 /win7 ntfs-3g defaults,user,noauto,uid=1000,gid=1000,umask=022 0 0 –  karthick87 Dec 19 '10 at 15:20

1 Answer 1

up vote 5 down vote accepted

With umask you define the options that should not be set. So umask=777 is the same as octal permission 000.

For some examples on how to convert between octal permissions and umask, see this Wikipedia entry.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.