Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Back when I used 10.04 LTS and would change my system volume via custom keyboard shortcuts I would always get a nice volume level box that would appear to the top right corner of the screen. I had this also happen when I changed my display brightness.

Now I am on 12.04 and using Unity desktop. When I change my display brightness the brightness level box appears as expected like so

enter image description here

but when I change my volume level via custom keyboard shortcuts I get no volume level box showing up indicating a volume change has taken place. All I see is that little panel notification speaker icon's sound waves change a little bit. 3 levels is not enough feed back though.

So how do I get a nice volume level box to show up when changing the volume?

UPDATE 1 Tried to fix the keyboard shortcuts using aleprovencio's suggestions but it broke what already did work.

enter image description here

UPDATE 2

Weird I am able to get the volume level box to show up when I use the volume wheel on my computer

enter image description here

but I want to make it show up with the custom keyboard shortcuts I created in Ubuntu Tweak like in the image below:

enter image description here

Now the question is:

What are the system commands that trigger both the volume changes and the volume level boxes to appear?

share|improve this question
    
That's strange, on my two notebook installs the volume notifications worked out of the box. –  Glutanimate Aug 28 '12 at 13:37
    
The volume level notification should still be there by default - see wiki.ubuntu.com/NotifyOSD#Volume_changes . I'm afraid I can't tell you where to configure this, though. –  Steve Kroon Aug 29 '12 at 8:15
    
That seems like a bug. Does the volume even change, or is it just the notification that is missing? –  Cumulus007 Aug 29 '12 at 21:58
    
@Cumulus007 Yes the volume changes when I use the commands: amixer ser Master toggle-q, amixer set Master 5%+-q and amixer set Master 5%--q like I show in UPDATE 2. I have those commands attached to keyboard shortcuts but they do not trigger the volume level box to appear. There must be another command to do that. Any ideas? –  max Aug 29 '12 at 22:12
    
So your keyboard does not offer dedicated keys to change your volume? –  Cumulus007 Aug 29 '12 at 22:50

3 Answers 3

Ahh. Finally I figured out how to make this work. I was trying to find a way to customize 12.04 keyboard shortcuts and came across a post on another forum. To fix this all I had to do was go

System Settings > Hardware > Keyboard > Shortcuts (tab) > Sound and Media

and the top three options are

  • Volume mute
  • Volume down
  • Volume up

To the right of those options are where the key combinations are located. Click on one of them and it says New Accelerator at which point you press your new shortcut key combo and presto.

enter image description here

share|improve this answer
    
That's correct. The way you were doing it before wasn't going to work because you were calling a command which bypassed the daemon which shows volume notifications. (And PulseAudio, for that matter, which can cause problems: it does some very handy stuff for us that isn't easily expressed when talking to amixer directly). When you set the volume control keyboard shortcut in System Settings, that is the shortcut being watched for by gnome-settings-daemon. It takes care of all the weird stuff on its own. –  Dylan McCall Sep 13 '12 at 20:10

The actions you're looking for are: XF86AudioRaiseVolume, XF86AudioLowerVolume and XF86AudioMute. Just assign the keyboard shortcuts to them and you're fine.

share|improve this answer
    
That did not work at all. Posted a screen shot. It actually broke my old working custom keyboard shortcuts for volume –  max Aug 29 '12 at 21:52
    
also look at UPDATE 2 –  max Aug 29 '12 at 22:13
    
aren't those the names of the custom keys? instead of the commands... –  Mateo_ Aug 30 '12 at 1:49

You can also try to install xfce4-volumed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.