Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up a server with a /29 network address (I've been given a subnet on my DSL connection).

I set the router's LAN IP to the gateway for the range (call it

I then proved the routing with a Windows box and pinging google - setting the IP address to and with a subnet of

Then I tried to set my server up - I downed the network service and edited the interfaces file:

auto eth0
iface eth0 inet static

But when I restarted the network service, I got a message SCIOADDRT no such process

I could ping the 177 computer, but not the gateway - and routing to external addresses was right out.

share|improve this question
up vote 4 down vote accepted

With a /29 your gateway address is not valid

248 = 11111 000 176 = 10110 000

Since it is a network address, not a valid host one.

Edit: Try router .177, winbox .178, linbox .179 and you should be fine.

share|improve this answer
this is only half an answer - if you think these are wrong, can you provide a suggestion on what they should be? (these are the settings I've been given by my ISP - and they work from the Windows machine) – HorusKol Aug 28 '12 at 12:16
1 gateway with netmask is definitively wrong. – Alessandro Carini Aug 28 '12 at 12:31
With a netmask host addresses fall within 177-182 range (e.g. - while .176 and .183 are network and broadcast adresses, and they can't be assigned to host or gateway. – Alessandro Carini Aug 28 '12 at 12:46
@HorusKol - It "shouldn't" have worked on your Windows machine. If it did, it's related to a 169 address getting defaulted towards and network voodoo taking over. This answer was right. – RobotHumans Aug 28 '12 at 12:59
Okay - that makes sense now, thanks. The answer might have been right, but it was still only half an answer – HorusKol Aug 28 '12 at 23:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.