Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

It shows that my laptop is now airplane mode, i can't turn on wifi. After i turned off the airplane mode, still can't turn on wifi. What is the problem?

share|improve this question
Can you paste the result of lspci | grep -i net. Also please check if your machine have any hardware wifi toggle button. If yes, make sure it is turned on. – devav2 Aug 28 '12 at 13:07

2 Answers 2

try restart. try sudo rfkill unblock wifi

share|improve this answer

Installed ubuntu on toshiba click2pro and hardware switch disabled appeared. Opened the laptop and removed the battery connection and put it back and everything is good to go. Bios was altered and it was set back. Made my day going.

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – A.B. Aug 27 at 9:51
@A.B. I don't see how this isn't an answer. If he was able to fix the issue by just opening up the laptop and disconnecting/reconnecting the power, then that's an answer. – RPi Awesomeness Aug 28 at 13:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.