Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As of today, my wubi installation of Ubuntu won't boot (goes straight to 'minimal bash-like interface) and I am unable to mount it when I boot straight to Ubuntu.

If I boot straight into Ubuntu (not using Wubi, not going via Windows), I am able to mount the Windows partition and see the Wubi partition there:

sudo mount -t ntfs /dev/sda5 /media/winxp

And from there I can see the wubi root disk:

/media/winxp/ubuntu/disks/root.disk

But if I try to mount this:

sudo mount -o loop /media/winxp/ubuntu/disks/root.disk /media/wubi

I get an error:

/media/winxp/ubuntu/disks/root.disk Input/Output Error

If I then try fsck:

sudo fsck /media/winxp/ubuntu/disks/root.disk

I get this: Input/Output Error while trying to open /media/winxp/ubuntu/disks/root.disk

The Superblock could not be read or does not describe a correct etx2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt and you might want to try running e2fsk with an alternate superblock:

e2fsck -b 8193 <device

... this gives me the same result.

There is data on this partition that I really need to be able to access, so I can't delete and reinstall.

Any help much appreciated. Thanks.

share|improve this question

closed as too localized by Marco Ceppi Feb 3 '12 at 0:48

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
this was the same reason i stopped using wubi. bcos it crashes after updating. I couldn't find a solution back then and just switched to default cd install. I think you should do the same. Also when you mount a disk, you can't mount from it again(unless an archive). That's why after the wubi install, you can't access the folders of windows in that same partition. –  dumb906 Dec 23 '10 at 7:24
    
This question seems abandoned, there is not further information or activity added to it for several months. I am flagging this to be closed by a moderator. If you think this issue is still affecting you you can flag a moderator to re-open it. –  Bruno Pereira Feb 3 '12 at 0:46
add comment

Browse other questions tagged or ask your own question.