Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an 8GB RAM System but Ubuntu 12.04 only detect 4GB by system start. Every time I reboot the System Ubuntu will detect the full 8GB RAM!?!?!?

AMD Zacate E350 APU Radeon HD 6310 512MB shared memory 8GB GSKILL RAM 2TB Segate Barracuda

share|improve this question
    
Can you post the output of free -m by editing your Qn. –  atenz Aug 28 '12 at 6:32
    
How many modules is it? Try removing one module, boot the machine, see how much ram is detected, and then try it with the other. You may have a bad module. –  Mitch Aug 28 '12 at 6:52
1  
Can you please post the output of uname -a and dpkg -l | grep linux-generic –  Histo Aug 28 '12 at 7:05
    
regarding @Histo comment: BOTH situations (when on 4 and when on 8 Gb). Maybe 1 mem stick is too slow(?) –  Rinzwind Aug 28 '12 at 7:46
    
did u enable / install PAE? –  penreturns Aug 28 '12 at 9:18

2 Answers 2

You need to run 64bit Ubuntu to address more than 4GB of ram.

share|improve this answer
4  
Not exactly true. Ubuntu uses a PAE kernel for 4+Gb and 32bits. en.wikipedia.org/wiki/Physical_Address_Extension –  Rinzwind Aug 28 '12 at 6:42
2  
pae kernel is only installed on 12.04 if the installer detects more than 3GB of free ram. I suspect this is the problem he is running a non PAE kernel. –  Histo Aug 28 '12 at 7:04
1  
hmmm and the reboot does activate a pae kernel? :-\ you could be on something there –  Rinzwind Aug 28 '12 at 7:46

I think you installed the 32bit version with the pae kernel. Enter in the terminal:

uname -a 

If you see pae mentioned or i386, you are using the 32bit version. To use the full amount of RAM you need to install the 64bit version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.