Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Some system details:-

Dell Inspiron N-4010 OS: Ubuntu 12.04 and Windows 7 Home Basic RAM: 2GB Processor: Intel Core i3

tejaskale@tejaskale-Inspiron-N4010:~$ sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf0000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1              63      787184      393561   de  Dell Utility
/dev/sda2   *      788480    21510143    10360832    7  HPFS/NTFS/exFAT
/dev/sda3        21510144   326270975   152380416    7  HPFS/NTFS/exFAT
/dev/sda4       326273022   625141759   149434369    f  W95 Ext'd (LBA)
/dev/sda5       326273024   509685759    91706368    7  HPFS/NTFS/exFAT
/dev/sda6       509687808   581951487    36131840   83  Linux
/dev/sda7       581953536   583952383      999424   83  Linux
/dev/sda8       583954432   591951871     3998720   82  Linux swap / Solaris
/dev/sda9       591953920   625141759    16593920   83  Linux

A few days ago, I decided to shift my Dropbox and .thunderbird folder to my NTFS (non-Windows) partition (/dev/sda5/). Hence, using PySDM, I activated the auto mount option. But after a day or two, I started getting the following message during boot:-

Mounting failed for the partition /media/New\ Volume.
Press S to skip mounting or M to manual mounting.

Then I tried disabling the auto mount using PySDM but saw that the partition had become read-only. After reading about the problem online, I realized that modification of the fstab file was a way to alleviate the problem. Using this very helpful tutorial (http://www.tuxfiles.org/linuxhelp/fstab.html), I modified fstab which now looks like this

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc               proc  nodev,noexec,nosuid              0  0  
# / was on /dev/sda6 during installation
UUID=c66c1971-3833-4c46-bf91-052554bc9b79  /                   ext4  errors=remount-ro                0  1  
# /boot was on /dev/sda7 during installation
UUID=a0a94302-df4a-4334-b31b-35fbd3905da4  /boot               ext4  defaults                         0  2  
# /home was on /dev/sda9 during installation
UUID=a65aa0c6-d155-48d8-aef8-cfed1dc9c215  /home               ext4  defaults                         0  2  
# swap was on /dev/sda8 during installation
UUID=144c77f0-ad85-44a3-9110-1f3385fb4940  none                swap  sw                               0  0  
# New Volume was on /dev/sda5 during installation
UUID=EA42F6C442F69513                      /media/New\040Volume  ntfs-3g  defaults,rw,noauto,user,sync       0  0

But then I found out that since this is a NTFS partition, I required ntfs-3g to mount it and it seemed that PySDM had modified/played around with it. A bit more reading told me that rebuilding ntfs-3g was the best option and I did that using this Ubuntu Forums post (http://ubuntuforums.org/showthread.php?t=1661757).

Now I begin with my two problem. Firstly, I see two icons for the same partition in Nautilus as can be seen here.

https://plus.google.com/u/0/photos/114237712218008220104/albums/5781582665947587857/5781582672481988322.jpg

When I click on the first 'New Volume', I get the following error

Error mounting: mount exited with exit code 1: helper failed with:
Error opening '/dev/sda5': Permission denied
Failed to mount '/dev/sda5': Permission denied
Please check '/dev/sda5' and the ntfs-3g binary permissions,
and the mounting user ID. More explanation is provided at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

When I click on the second 'New Volume', the drive is mounted with read-write capability, but I also get the following message

Unable to mount New Volume
Timeout waiting for mount to appear

My second problem is that the inflow and outflow of files from 'New Volume' is very slow. Earlier, while copying a video file from a USB stick to 'New Volume' used to take place at speeds of around 2MB/sec but now it barely touches 50kB/sec. Also, if I try to download any file into that drive, Firefox simply crashes. Since one of my external hard disks, when failing, saw such reduction in file transfer speeds, I checked the SMART status of my hard disk but the results seem to indicate a healthy disk

tejaskale@tejaskale-Inspiron-N4010:~$ sudo smartctl --health -d ata /dev/sda
smartctl 5.41 2011-06-09 r3365 [i686-linux-3.2.0-29-generic-pae] (local build)
Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED
Please note the following marginal Attributes:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
190 Airflow_Temperature_Cel 0x0022   048   036   045    Old_age   Always   In_the_past 52 (31 204 52 26)

Any help with either of the problems would be highly appreciated.

Tejas

share|improve this question

closed as too localized by Mateo, vasa1, Seth, Eliah Kagan, Eric Carvalho Apr 10 '13 at 0:03

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
See also: askubuntu.com/questions/46588/how-to-automount-ntfs-partitions. It may be a good idea to not use special characters or blanks in mount points or disk labels. –  Takkat Aug 28 '12 at 7:07

Browse other questions tagged or ask your own question.