Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to upgrade a very old version of Ubuntu to a recent one, so I made the following steps:

  1. I created a large (over 30GB) tar.gz archive containing all data from my home directory
  2. Moved it to NTFS partition
  3. Launched Ubuntu 12.04 from CD
  4. Resized the NTFS partition during installation
  5. Completed the installation

Then I launched my brand new Ubuntu and wanted to copy the archive so:

  1. I mounted the partition on which the archive was located
  2. I have run ls -l in the place of file size, modification date etc., a ? appeared instead of any values
  3. I launched Windows XP which is installed on the same machine and it did not show that file on the partition at all
  4. Linux also does not show the file anymore

I tried running chkdsk under Windows which did not fix the problem. I also tried ntfsundelete in Linux which shows that this file cannot be recovered.

I would appreciate any help very much! I have lost a lot of data. What could have happened? Is there any chance of recovering this file?

share|improve this question

2 Answers 2

Two things could have happened.

1)The resize/shrink had some bug that caused the file to get "lost" (possible, but not horribly likely)

2)The partition was forcibly unmounted before cached disk writes were flushed (a lot more likely with a 30GB write to an external drive, even moreso if you piped tar or something to that effect)

In the prior case, recovery may be possible with FTK, foremost, scalpel, or some other tool. In the latter case, complete recovery is a LOT less likely.

Either way, complete recovery is less than likely.

share|improve this answer

I'd try with human error - is there a chance that you didn't uncheck "format" checkbox for this ntfs partition?

share|improve this answer
    
No, that is not possible - all other files on the partition remained untouched. –  Pawel Aug 27 '12 at 23:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.