Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm a new user to Ubuntu and Linux as a whole, I've had it for a few months and just as I'm starting to get a feel for things my wireless decided to quit on me. This puzzled me so i checked all the switches on the Vaio; my wireless switch was on (my bluetooth was also working), and in my windows partition the problem is non-existent. Help please? Anyways after executing the "rfkill list" command this was the outcome:

1: sony-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
2: sony-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
4: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

As stated in the title my laptop is a Sony Vaio PCG-71315L

EDIT- Shortly after a few more failed attempts i was looking around and found this forum question with roughly the same problem, anyways they resolved it by switching the wifi off via the actual switch, then entering "rfkill block wifi" into the terminal, i then turned the wifi switch to on and entered "rfkill unblock wifi" into the terminal. It almost fixed it, it now picks up wifi but when my wifi's name and passphrase are entered (and have been entered correctly, many many times) it refuses to connect, thanks for the help thus far, any ideas pertaining this problem?

share|improve this question
up vote 0 down vote accepted

As I see in your rfkill list your wifi is blocked by hardware, try to unlock it by pressing combination to turn your wifi on, on most laptops fn+Fx key, make sure fn key is in legasy mode. You can do it in Bios.

share|improve this answer
The special thing with the Vaio's (well as far as mine goes) is that the wifi switch is an actual physical switch on the bottom front of the laptop, it has been switched on the whole time. Any other ideas? – Luke Rossi Aug 28 '12 at 1:03
Sorry for my inattention, it was deep night, but it's soft block, did you try sudo rfkill unblock all ? – Yaroslav Tsymbalyuk Aug 28 '12 at 5:45
Yes that seems to have worked, finally. Thank you for the help :p – Luke Rossi Aug 29 '12 at 13:08

If Windows is installed along Ubuntu, try login into Windows and switch in that OS. In an occasion I switch off wifi in Windows and it locked the hardware switch in Ubuntu.

share|improve this answer
I originally thought that as well, when i did it was, internally though through a management software, after switching it to on, i restarted to Ubuntu (12.04) and the problem persisted – Luke Rossi Aug 28 '12 at 1:04

The steps that work for me most of the time:

  1. Turn off power.
  2. Remove battery.
  3. Unplug from wall.
  4. Attempt to power on several times with all power sources disconnected.
  5. Reconnect as normal. Boot.
share|improve this answer
Wait, so disconnect all power sources and the battery from the computer and try to boot it? – Luke Rossi Aug 28 '12 at 1:17
exactly so. it removes the power from where the wireless card tries to save its "hardware disabled" state – RobotHumans Aug 28 '12 at 1:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.