Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a wired network connection that should be manually configured. Which is working in my parallel boot Windows XP. But in my Ubuntu 10.10 after giving same values of IP address, subnet Mask, Default Gateway and DNS Servers the wired network connection is shown as active but Firefox is not detecting any connection.

share|improve this question
    
How did you configure your connection?? –  karthick87 Dec 19 '10 at 7:56
    
yes i did . after that it showed network connection active.. –  Tony John Dec 19 '10 at 8:00
    
can you post the output of ifconfig –  karthick87 Dec 19 '10 at 8:00
    
from top Network icon . edit network connection... –  Tony John Dec 19 '10 at 8:01
    
eth0 Link encap:Ethernet HWaddr 00:e0:1c:3b:da:0a inet addr:192.168.5.210 Bcast:192.168.255.255 Mask:255.255.0.0 inet6 addr: fe80::2e0:1cff:fe3b:da0a/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:9829 errors:2 dropped:0 overruns:0 frame:0 TX packets:543 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1547519 (1.5 MB) TX bytes:119509 (119.5 KB) Interrupt:19 Base address:0xb800 –  Tony John Dec 19 '10 at 8:02
show 12 more comments

3 Answers 3

Try manually setting an IP address for your device.

It looks like your broadband router is 192.168.2.1, so follow these steps :

  1. Right click on the network manager applet and choose "Edit Connections..."
  2. In the "Wired" tab, click the "Add" button.
  3. Enter a Connection Name like "My Manual Connection"
  4. Click on the IPv4 Settings tab.
  5. Change the "Method" to "Manual".
  6. Under "Addresses" click on "Add"
  7. Put 192.168.2.50 for Address. Put 255.255.255.0 for Netmask. Put 192.168.2.1 for Gateway.
  8. For nameserver, put 192.168.1.1 and 208.67.222.222 (the second address is openDNS, a free DNS server that anyone can use).
  9. Click on the "Add" button at the bottom.
  10. Now activate your newly created profile - left click on the network manager applet, then choose your newly created connection.

Now try pinging your gateway with ping 192.168.2.1. You should see something like this :

scaine@GroovyTosh:~$ ping 192.168.2.1
PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
64 bytes from 192.168.2.1: icmp_req=1 ttl=255 time=0.378 ms
64 bytes from 192.168.2.1: icmp_req=2 ttl=255 time=0.358 ms
64 bytes from 192.168.2.1: icmp_req=3 ttl=255 time=0.546 ms

If this works, then you have an issue with your DHCP server which is issuing incorrect CLASS B (255.255.0.0) subnet masks and might not be setting your default route correctly.

However, if this does work, then you should be able to run with this configuration without any issues.

share|improve this answer
add comment

Is your Firefox working online? Sometimes it switches to offline and don't back to online. Check if your File > Work Offline menu is unchecked.

share|improve this answer
add comment

I would suspect that your subnet mask is set wrong. The 192.168.x.x range of addresses are normally set up as class C networks with a mask of 255.255.255.0. It won't work correctly if you have it set wrong.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.