Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my dual booting laptop, I have Windows XP and Ubuntu 12.04. I've had XP on the laptop for years, and install Ubuntu 12.04 a few months ago. For some reason, Ubuntu 12.04 has stopped working.

When I power on the laptop, I get the grub menu, and I can select Windows XP or Ubuntu 12.04. If I select Windows XP, it boots up perfectly and I can use it as normal. However, if I select Ubuntu 12.04, It just displayed a terminal type blank screen with no text except the blinking cursor, but no commands execute if I try typing something in.

How do I fix this so I can boot back into Ubuntu 12.04? I know I can try a reinstall, but I don't want to lose the files I have in Ubuntu 12.04. Is it possible to somehow do a repair?

share|improve this question
    
It's hard to tell what the error is in this case. Try accessing your log files by using a live stick. –  André Stannek Aug 30 '12 at 8:14
    
A little tip if it turns out you have to reinstall: Create a new partition for /home. This way you will not use your files on reinstall. Except some configuration in /etc. –  André Stannek Aug 30 '12 at 8:17
    
I really don't know. If you did not encrypt your home folder (you are alive) then you can boot from a LiveCD or a LiveUSB (you must select the Test Ubuntu option) and copy your files into any Windows OS partition. I would perhaps boot from Windows OS to test if all these files where saved. Once again you can boot from the same LiveCD or LiveUSB and reinstall your system. –  Salvador Aug 30 '12 at 17:56
    
Don't you have the "recovery mode" option in grub? Have you tried that? –  Anwar Shah Aug 31 '12 at 12:46
    
@Anwar, yes, but it keeps giving me a bus error message. –  oshirowanen Aug 31 '12 at 12:50

3 Answers 3

There are many things that could have happened.

  • you can try reinstalling grub.
  • try booting with usb/live cd and hunt for issue there, ie, disk check, log check
  • you can try to access recovery in the grub menu list, maybe its a graphics error
share|improve this answer

It is possible that the grub MBR has been damaged, or that it is pointing to the wrong place for Ubuntu.

You can repair the grub using BootRepair (https://help.ubuntu.com/community/Boot-Repair).

Alternatively, you can try this simple procedure first. If it doesn't solve the problem, use BootRepair:

  1. Boot with Ubuntu Live CD

  2. Open terminal (command prompt)

  3. Type: sudo fdisk -l

You will get a list of partitions, similar to the following list:

/dev/sda1 13 102400 de Dell Utility
/dev/sda2 * 13 1926 15360000 7 HPFS/NTFS
/dev/sda3 1926 30892 232676566 7 HPFS/NTFS
/dev/sda4 30893 60802 240245761 5 Extended
/dev/sda5 30893 59584 230467584 83 Linux
/dev/sda6 59585 60802 9777152 82 Linux swap / Solaris 

Ubuntu partition is the one with the name "Linux" (not necessarily the one with the star, although could be). On this case is on '/dev/sda5' so we have to mount it:

  1. sudo mount /dev/sda5 /mnt (replace 'sda5' with the partition name in your case)

  2. And then install grub: sudo grub-install --root-directory=/mnt /dev/sda

  3. Reboot and verify that all is working fine.

Hope that helps!

share|improve this answer

I had more or less the same problem last week... I booted ubuntu (from hibernation) and when ubuntu had exited the hibernation, I had access to nothing. It is like ubuntu was ok but no launcher, no keystrokes, nothing at all... Nothing was possible... I tried several thing but nothing did... As last resort I reinstalled ubuntu. Great care here. You ask the installer to reinstall an existing installation (no formatting !!!). Your home is preserved ! The installer will reinstall all the packages that were previously installed and it worked for me. var is overwritten, so by example as the home of postgres was in var, this one was gone...

share|improve this answer
    
I've downloaded the desktop live cd and have booted from it, selected the install option and i get 3 options, full wipe install which will wipe the entire hard drive, reinstall ubuntu, which will wipe the ubuntu partitions, and other which lets me configure the partitions. I don't see a reinstall option without a wipe warning. –  oshirowanen Oct 7 '12 at 15:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.