Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On 12.04 64-bit, about every 5 seconds my screen blinks twice. Even during installation of Ubuntu from CD, this happens during the complete process.

I had no problems with earlier Ubuntu versions (earlier version was 10.04LTS 64-bit)

System specs:

  • I7-2600K
  • MSI 7681 Motherboard
  • 16 GB RAM
  • 2 x Nvidia 560 card SLI (only 1 screen on 1 card active during install process)

This flickering is driving me crazy, please help.

share|improve this question
    
Did you check if it only occurs when using only the laptop battery as source of power? That's my case. If I connect the charger the problem finishes. I don't know how to solve it... –  Luis J. Romero Aug 22 at 22:57

1 Answer 1

Try this to make sure you have the best driver for nvidia cards

Add the PPA for nvidia

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

Update software sources

sudo apt-get update

Download the driver

sudo apt-get dist-upgrade

Then reboot

This fixes many nvidia issues so may help you

share|improve this answer
    
The original version of drivers did good on my setup. After installing the latest drivers using the above procedure the blinking effect appeared. I'm currently using the 304 version. –  Matthias Hryniszak Apr 4 '13 at 20:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.