Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm developing a program for 12.04 that will run on full-screen, so I would like to have full control of what appears on the screen.

However, when I show another window (possibly a dialog/message box), the Unity Panel and Launcher appears on the top and left side of the screen. I've experienced this behavior with other applications (Firefox, Gnubg) as well when in full-screen mode.

I tried to play with the settings, now my dialog box is hidden from the the taskbar, set to float on it's parent, which is my full screen window. The problem still exists.

Is there a way to prevent these panels from showing up, when the new window isn't shown in taskbar, or it's parent is a full-screen window? Or do I need to completely disable them?

share|improve this question

1 Answer 1

This is a bug in Ubuntu that I've noticed.

It could possibly be related to this: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/748539

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.