Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Nothing works, whether it's an update, or software, or anything, even on Synaptic. I found another similar thread, and tried that but that didn't work. Synaptic is giving me the following message:

E: avg2012flx: subprocess installed post-installation script returned error exit status 1

The software center gave me this message:

InstallArchives() failed: (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 224115 files and directories currently installed.)
Removing testdisk-dbg ...
Removing testdisk ...
Processing triggers for man-db ...
Setting up avg2012flx (2012.1793) ...
Installing 'avgd' service initscripts...
ln: failed to create symbolic link `/etc/init.d/avgd': File exists
dpkg: error processing avg2012flx (--configure):
subprocess installed post-installation script returned error exit status 1
share|improve this question
    
Try running sudo dpkg -r avg2012flxfrom the terminal. –  Peachy Aug 28 '12 at 1:39

1 Answer 1

This is a bug in the avg2012flx package, specifically in its post-installation script. It looks like this version of the package doesn't handle upgrades properly.

The easiest solution would be to wait for a fixed version of the package. Since this seems to be a third-party package, you'd have to report this as a bug to whoever made that package.

You should be able to work around the bug by moving the /etc/init.d/avgd file out of the way:

sudo mv /etc/init.d/avgd /etc/init.d/avgd.old
sudo apt-get -f install

This may leave avgd in a non-working state or cause other trouble. Alternatively, reinstall the old, working version of the avg2012flx package and mark it as on hold until a fixed version comes out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.