Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I recently upgraded my desktop mac to Precise and now can't get past the Ubuntu 12.04 splash page. The splash freezes with

[   19.931097] b32-phy0 ERROR: Firmware file "b43/ucode16_mimo.fw" not found
[   19.9311126] b32-phy0 ERROR: You must go to and download the correct firmware for this driver version.  Please carefully read all instructions on this website.

written on it

This is when I choose 3.2.0-generic from the grub menu. If I choose to load up older kernels, I still get the same thing.

How can I make my computer finish booting again?

I'm able to ssh into the machine and poke around, but the actual screen freezes at the splash.

The firmware error is now gone ,but I still can't get past the splash screen


cat kern.log

share|improve this question
Why are you using GDM instead of the default lightdm? Please share the content or output of the following commands/files to better help us troubleshoot your problem (instructions in this answer): file(s): /var/log/kern.log, command(s): dmesg – izx Sep 8 '12 at 10:41
I probably am using LightDM if that's the default. I haven't kept up with all of ubuntu's "innovations" since I don't use Gnome/KDE, so I never see them. I'll pastebin that stuff, but, as @turbo points out below, I should really open up another question since the b43 wireless problem wasn't the cause of the machine not booting. – John Baber-Lucero Sep 8 '12 at 14:50

1 Answer 1

up vote 2 down vote accepted

If you've got the possibility to connect to the internet by cable - highly likely if you can ssh into your machine - run jockey-text and see if this helps.

If this doesn't solve the issue just download the firmware from and just manually extract/copy it to /lib/firmware/b43/. Use scp for copying. If you can install b43-fwcutter and run b43-fwcutter -i to see what device you're on (if you don't already know).

If both ways fail update your question with details. The Ubuntu Wiki bcm43xx page has some details to continue the debugging.

share|improve this answer
The advice at to apt-get install firmware-b43-installer seemed to get rid of the b43 error. But my machine is still hanging at the splash screen. Thank you for helping me fix that error! If nobody can get me past that, I guess you get the bounty and I'll set up another question asking "How do I get past the splash screen?" – John Baber-Lucero Sep 7 '12 at 15:38
Why don't you open another question with dmesg output and so on? Would have been strange if the WiFi had blocked all of the boot-up. – turbo Sep 7 '12 at 19:23
Okay, I've asked about the general freeze. – John Baber-Lucero Sep 10 '12 at 12:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.