Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying for hours just to install one program. In this time, I've tried my best to follow directions and not screw everything up but I have. I'm new to Linux. I tried to install Firestorm and this is what happened:

parent@ubuntu:~$ sudo '/home/parent/Downloads/Phoenix_Firestorm-Release_i686_4.2.1.29803/install.sh' 
[sudo] password for parent: 
Enter the desired installation directory [/opt/firestorm-install]: /home/parent/downloads
 - Installing to /home/parent/downloads
/home/parent/Downloads/Phoenix_Firestorm-Release_i686_4.2.1.29803/install.sh: line 80: /home/parent/downloads/etc/refresh_desktop_app_entry.sh: Permission denied
parent@ubuntu:~$ sudo opt/firestorm-install
sudo: opt/firestorm-install: command not found
parent@ubuntu:~$  ./etc/refresh_desktop_app_entry.sh
bash: ./etc/refresh_desktop_app_entry.sh: No such file or directory
parent@ubuntu:~$ sudo '/home/parent/Downloads/Phoenix_Firestorm-Release_i686_4.2.1.29803/install.sh' 
Enter the desired installation directory [/opt/firestorm-install]: /home/parent
 - Backing up previous installation to /home/parent.backup-2012-08-27
 - Installing to /home/parent
cp: cannot stat `/home/parent/Downloads/Phoenix_Firestorm-Release_i686_4.2.1.29803/*': No such file or directory
Failed
parent@ubuntu:~$

Now whenever I go into my files it says it can't find anything. Like Cannot find home/parent/Downloads. Now, I KNOW there are downloads. I don't know why it's doing this all of a sudden. I'm so frustrated that I'm ready to just go back to Windows. I've already had to uninstall/reinstall Ubuntu once today. It's looking like I"m going to have to do it again. How can I fix my file problem that I'm now having and can someone please, please tell me how to install Firestorm? I mean they don't even have their repository listed. It's ridiculous to have to go through this over a program. Spotify wasn't hard at all to install so why is this? Someone please help, and I'm sorry if I sound like a total idiot. I'm pretty tech savvy but I'm honestly pretty upset after struggling with this for hours.

Edit Okay, I see the problem with the directory files (showing the error I mentioned above when I try to click on them). I can only access my downloads, desktop, ect, through the backup that was created when I tried to install Firestorm. It's like that's the real home now. How can I get it back to the way it was?

Edit Ubuntu has stopped working for me on reboot now. It doesn't go past the login screen. This is exactly what happened when I had to uninstall it before after trying to install Firestorm. Maybe I'm giving up too easily but I think I'm just going to go back to Windows. If this is what's going to happen every time I innocently try to install a program then it's just not worth it. I installed it specifically to run Firestorm because Windows sucks up a lot of CPU and causes lag. I still appreciate any input but this is just too much hassle for something that shouldn't be hard.

share|improve this question
    
Is your processor 64bit? I never had problems with Firestorm viewer until I bought a new laptop which had a i7 processor (64bit) and then by installing ubuntu 12.04 and 13.04 64 bit, the problems started. If so, google for kokua viewer (worked for me for a few days then it stopped without a reason) and singularity 64bit. singularity runs fine on my system. –  Deus Deceit Jun 12 '13 at 5:21
    
You could always try installing Ubuntu in a virtual machine. –  Sparhawk Nov 16 '13 at 0:55

3 Answers 3


I had a go running the same program. It worked fine for me.

According to the 'README-linux.txt' file:

The Firestorm Linux client can entirely run from the directory you have unpacked it into - no installation step is required

Run ./firestorm from the >installation >directory to start Firestorm.

So in my case, running the program was relatively simple:

Go to the Downloads folder, extract the archive, and then go into the extracted Phoenix folder:

cd ~/Downloads/
tar -xvf Phoenix_Firestorm-Release*.tar.bz2
cd ./Phoenix_Firestorm-Release*

Provide a script with permission to execute. Executing the script then adds Firestorm to the menu.

chmod u+x ./etc/refresh_desktop_app_entry.sh
./etc/refresh_desktop_app_entry.sh

After that Firestorm should appear in your menu. It can then be run directly from the extracted archive.

I think your problem with logging in may related to this output:

parent@ubuntu:~$ sudo '/home/parent/Downloads/Phoenix_Firestorm-Release_i686_4.2.1.29803/install.sh'
Enter the desired installation directory [/opt/firestorm-install]: /home/parent
- Backing up previous installation to /home/parent.backup-2012-08-27
- Installing to /home/parent
cp: cannot stat `/home/parent/Downloads/Phoenix_Firestorm-Release_i686_4.2.1.29803/*': No such file or directory
Failed

In particular, it seems as if you choose to install the program in the same location as your home directory (due to typing '/home/parent' at the command prompt). Therefore, the installer moved the contents of the home directory to "/home/parent.backup-2012-08-27", which would have lead to some important files being moved.

share|improve this answer

You need to be careful with what you type into the command line. I can see quite a few typos in your paths.

  • You sometimes type Downloads and sometimes type downloads.
  • opt/firestorm-install should be /opt/firestorm-install, which is why you get the error sudo: opt/firestorm-install: command not found
  • Finally, ./etc/refresh_desktop_app_entry.sh looks strange. Should it be /etc/refresh_desktop_app_entry.sh?
share|improve this answer

is you problem solved ? this is how i found firestorm running on ubuntu 12.04 even if you are running in 64 bit, you need to install 32 bit library

sudo apt-get install ia32-libs

hope that works.

share|improve this answer

protected by Community Nov 7 '13 at 15:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.