Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get into X by startx (not lightdm).

How can I define the default gnome session (gnome-classic instead of 2d/3d) system-wide for all users?

share|improve this question
    
Are you asking two question here? How to fix for not having to use startx and setting gnome-classic as default session? –  Anwar Shah Sep 3 '12 at 4:51
    
I got this error: update-alternatives: error: alternative /usr/bin/gnome-session-fallback for x-session-manager not registered, not setting. Any ideas? –  user268859 Apr 14 at 15:57
    
I still got the same error. Looks like gnome-session-fallback isn't registered. If I run this: update-alternatives --list x-session-manager I only get 1 result: /usr/bin/gnome-session From the help menu I'm seeing install with these options: --install <link> <name> <path> <priority> Thought maybe I could install gnome-session-fallback with this command: sudo update-alternatives --install /usr/bin/gnome-session-fallback gnome-session-fallback /usr/bin/x-session-manager 1 But I get errors after: > update-alternatives: using /usr/bin/x-session-manager to provide /usr/bin/gnome-session-fallback (g –  user268859 Apr 14 at 16:30

1 Answer 1

The thing that gets run is x-session-manager, and this is managed through the alternatives system.

sudo update-alternatives --set x-session-manager /usr/bin/gnome-session-fallback
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.