Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My ability to update stopped recently, with all calls to *ubuntu.com and ubuntuforums.com failing completely. Things just time out, but other sites work just fine.

It's happening upstream of my router; traceroute from my router fails to connect. It's not on my computer either; when connected on wifi, my Android phone fails to connect also, but when I get off wifi my phone gets to ubuntu.com without problems.

I can visit ubuntu.com in a browser only if I go through an anonymous proxy.

The problem isn't DNS, either, as it resolves an IP address, but I tried a few different DNS servers just in case.

I've tried updating my repositories in package manager, but they all also fail.

What happened? Is it possibly my ISP blocking all traffic to ubuntu.com and the mirror domains? Is ubuntu mad at my IP address or range?

I am running Linux Mint 13, Kernel 3.2.0-26-generic-pae.

share|improve this question

closed as off topic by roadmr, hbdgaf, Jjed, izx, Stephen Myall Aug 27 '12 at 18:14

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
It could also be that Mint is jealous and does not want Mint users checking out the sexy curves of other... more experienced distros ^^. –  Luis Alvarado Aug 27 '12 at 1:47
    
Mint is built on top of Ubuntu, so probably not that. Maybe Ubuntu is angry that I'm using Mint instead of their increasingly frustrating interface. –  Bob Baddeley Aug 27 '12 at 3:07

4 Answers 4

up vote 2 down vote accepted

Please have a look at this thread, especially my answer. Could this be your issue? It started about 24 hours ago.

share|improve this answer
    
Yes! This is consistent with what I've been seeing. Thank you. –  Bob Baddeley Aug 27 '12 at 16:14

You appear to have an ISP that is blocking the connection to a particular site. This case, ubuntu.com. I also had to deal with this via a anonymous proxy.

This is all true, assuming you do not have a firewall/router/network device that is blocking your connection to this site.

Can you use another ISP service provider with your own PC and see if this is still true. In my case I had several russian sites blocked.

NOTE: Also remember that this site is ubuntu specific. For other versions (Including derivatives) you can go to other stack exchange sites like for example Unix & Linux).

share|improve this answer
    
Thanks, Luis. I put it in this forum because it was about ubuntu.com blocking me, and not a question specific to the OS. Using an anonymous proxy is allowing me to make progress, albeit slow. It seems odd that Charter would be blocking it. –  Bob Baddeley Aug 27 '12 at 3:06
    
I recommend to try what I did. Ask a friend for just a moment to give you a couple of minutes with their ISP (Assuming is another ISP). That way you will know for sure. –  Luis Alvarado Aug 27 '12 at 4:08

Bob - I'm having the exact same issues and my ISP is also Charter. I just got off the phone with their tech support and they said they are not blocking Ubuntu.com or any of it's subdomains on their end. The tech is going to pass a note on to my local office to make sure there's not any routing issues though. I really don't know what's going on because I can access it on my cell (once I take it off my wifi) and at my office. I've tried several different DNS servers (OpenDNS, Google & Charter) and it doesn't make any difference.

share|improve this answer

I had same problem after update like you, and just close my modem waited 15 seconds and open it again. And problem solved :)

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.