Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

What do I need to so that mailman, and also dovecot-postfix, use the FQDN of Or, at least, so that mailman is usable on localhost.

root@dur:~# newlist mailman
Enter the email of the person running the list:
Initial mailman password: 
Create a new, unpopulated mailing list.

Usage: /usr/sbin/newlist [options] [listname [listadmin-addr [admin-password]]]


    -l language
        Make the list's preferred language `language', which must be a two
        letter language code.

    -u urlhost
        Gives the list's web interface host name.

    -e emailhost
        Gives the list's email domain name.

        Normally the administrator is notified by email (after a prompt) that
        their list has been created.  This option suppresses the prompt and

        Print this help text and exit.

You can specify as many of the arguments as you want on the command line:
you will be prompted for the missing ones.

Every Mailman list has two parameters which define the default host name for
outgoing email, and the default URL for all web interfaces.  When you
configured Mailman, certain defaults were calculated, but if you are running
multiple virtual Mailman sites, then the defaults may not be appropriate for
the list you are creating.

You also specify the domain to create your new list in by typing the command
like so:

    newlist --urlhost=www.mydom.ain mylist

where `www.mydom.ain' should be the base hostname for the URL to this virtual
hosts's lists.  E.g. with this setting people will view the general list
overviews at http://www.mydom.ain/mailman/listinfo.  Also, www.mydom.ain
should be a key in the VIRTUAL_HOSTS mapping in if
the email hostname to be automatically determined.

If you want the email hostname to be different from the one looked up by the
VIRTUAL_HOSTS or if urlhost is not registered in VIRTUAL_HOSTS, you can specify
`emailhost' like so:

    newlist --urlhost=www.mydom.ain --emailhost=mydom.ain mylist

where `mydom.ain' is the mail domain name. If you don't specify emailhost but
urlhost is not in the virtual host list, then mm_cfg.DEFAULT_EMAIL_HOST will
be used for the email interface.

For backward compatibility, you can also specify the domain to create your
new list in by spelling the listname like so:


where www.mydom.ain is used for `urlhost' but it will also be used for
`emailhost' if it is not found in the virtual host table. Note that
'--urlhost' and '--emailhost' have precedence to this notation.

If you spell the list name as just `mylist', then the email hostname will be
taken from DEFAULT_EMAIL_HOST and the url will be taken from DEFAULT_URL (as
defined in your file or overridden by settings in

Note that listnames are forced to lowercase.

The list admin address need to be a fully-qualified address, like, not just owner.

Illegal list name: mailman@dur
root@dur:~# cat /etc/hostname
share|improve this question
others seem to have a similar problem: no solution. – Thufir Aug 27 '12 at 3:30 doesn't have any troubleshooting info which I see. – Thufir Aug 27 '12 at 4:01

I think I got it:

root@dur:/etc/mailman# newlist mailman
Enter the email of the person running the list:
Initial mailman password:
To finish creating your mailing list, you must edit your /etc/aliases (or
equivalent) file by adding the following lines, and possibly running the
`newaliases' program:

## mailman mailing list
mailman:              "|/var/lib/mailman/mail/mailman post mailman"
mailman-admin:        "|/var/lib/mailman/mail/mailman admin mailman"
mailman-bounces:      "|/var/lib/mailman/mail/mailman bounces mailman"
mailman-confirm:      "|/var/lib/mailman/mail/mailman confirm mailman"
mailman-join:         "|/var/lib/mailman/mail/mailman join mailman"
mailman-leave:        "|/var/lib/mailman/mail/mailman leave mailman"
mailman-owner:        "|/var/lib/mailman/mail/mailman owner mailman"
mailman-request:      "|/var/lib/mailman/mail/mailman request mailman"
mailman-subscribe:    "|/var/lib/mailman/mail/mailman subscribe mailman"
mailman-unsubscribe:  "|/var/lib/mailman/mail/mailman unsubscribe mailman"

Hit enter to notify mailman owner...

root@dur:/etc/mailman# ll
total 52
drwxr-xr-x   3 root list  4096 Aug 27 11:46 ./
drwxr-xr-x 170 root root 12288 Aug 27 11:17 ../
-rw-r--r--   1 root root  2477 Oct 19  2011 apache.conf
drwxr-xr-x   2 root root  4096 Aug 26 16:32 en/
-rw-r--r--   1 root root     0 Aug 26 16:32 leftover
-rw-r--r--   1 root root  4370 Aug 27 11:48
-rw-r--r--   1 root root  4344 Aug 27 11:46
-rwxr-xr-x   1 root root  6240 Oct 19  2011*
-rwxrwxr-x   1 root root  4090 Oct 19  2011*
root@dur:/etc/mailman# diff
> DEFAULT_URL_HOST   = 'dur'
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.