Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I turned on my computer today and when I tried to run updates through Update Manager, it would just sit there slowly loading a repository forever.

Then I tried to access and it wouldn't load. Then I tried,, and none of them will load. Everything was working fine yesterday, but now the only sites I can access seem to be anything non Ubuntu related (Google, Yahoo, Twitter, IMDB, they all work).

This is one of the strangest things I've encountered and I can't figure it out.

share|improve this question

It is very likely, that you are suffering from a problem at Telia Sonera. They have major network problems in London, close to Canonicals own networks that host Ubuntu related services.

To see if you are affected, open a terminal and make sure traceroute is installed (sudo apt-get install traceroute), then type traceroute | grep --color=auto telia. If your universe repository is also based at Canonical (e.g. not a local mirror), see below on how to install traceroute withouth apt.

If this command outputs anything, then Telia is most likely the cause of your problems. If this command does NOT output anything, it is still possible, that you are affected, because of asynchronous routing.

This problem is not within Canonicals reach, so they cannot really do something about it (besides building global redundancy), but it should be temporary.

(This answer is only valid close to the time of writing! If you read this in a couple of weeks or months, then this does most likely NOT help you!)

How to install traceroute without apt You can download traceroute from a mirror that is not affected by that issue and install it via dpkg.

For amd64 arch run wget && sudo dpkg -i traceroute_2.0.18-1_amd64.deb

For i386 arch run wget && sudo dpkg -i traceroute_2.0.18-1_i386.deb

share|improve this answer
+1 , Just clarification, If the OP is unable to update, how would he install traceroute, is there any other option. Thanks – atenz Aug 27 '12 at 12:48
Apologies, I live in a country, where Ubuntu automatically configures local mirrors for regular install, so for me only is the issue. I will update my post to address this issue. – pgschk Aug 27 '12 at 12:53

Try to run this command on your terminal to find out if there's an errors on some applications and packages. I hope it will help.

sudo apt-get -f install

Read more:

share|improve this answer
What is that command supposed to do? – user85741 Aug 26 '12 at 23:18
I tried it, but the problem seems deeper than that. I've tried to search around for people with similar problems but there isn't much out there. I just can't quite figure out why only these specific sites seem to be affected. – user85741 Aug 27 '12 at 1:28
This is a network problem. Installing dependencies and fixing broken packages is unrelated. – hexafraction Aug 27 '12 at 13:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.