Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was following @Alex's answer about my other question.

My GPU is GeForce GT 540M.

I installed bumblebee and bumblebee-nvidia packages. And reboot, i get this error :

none of the selected modes were compatible with the possible modes: Trying modes for CRTC 310 CRTC 310: trying mode 640x480@73Hz with output at 1920x1080@51Hz (pass 0) CRTC 310: trying mode 640x480@73Hz with output at 1920x1080@51Hz (pass 1)

and resolution reduced to 640*480 px. After that i uninstall bumblebee,

sudo apt-get remove bumblebee bumblebee-nvidia

And then, i followed this instructions for this error. They said, delete your monitors.xml file. And i delete it. But it's not restored. There are only 1024x768 and 640x480 . My original resolution was 1920x1080.

I tried unity --reset after this, i get Compiz closed unexpected error.

enter image description here enter image description here

Tried to install latest NVIDIA drivers :

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

sudo apt-get update

sudo apt-get install nvidia-current

Still there isn't 1920x1080 on Displays screen.

I want to restore my monitors.xml file and solve my problem.

UPDATE

I just reinstall my Compiz. Now i don't get COMPIZ error when unity --reset

share|improve this question
    
Can you attach your /var/log/Xorg.0.log file somewhere? –  Lekensteyn Aug 26 '12 at 21:53
    
@Lekensteyn , pastebin.ca/2198290 –  Eray Aug 26 '12 at 21:58

1 Answer 1

up vote 1 down vote accepted

Somehow your driver installation got screwed up which broke the nvidia kernel/Xorg driver combination:

[    20.437] (II) LoadModule: "nvidia"
[    20.463] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    21.054] (II) Module nvidia: vendor="NVIDIA Corporation"
[    21.054]    compiled for 4.0.2, module version = 1.0.0
[    21.054]    Module class: X.Org Video Driver
[    21.088] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[    21.088] (EE) NVIDIA:     system's kernel log for additional error messages.
[    21.088] (II) UnloadModule: "nvidia"
[    21.088] (II) Unloading nvidia
[    21.088] (EE) Failed to load module "nvidia" (module-specific error, 0)

Try purging the nvidia driver:

sudo apt-get purge nvidia-current

If the file /usr/lib/x86_64-linux-gnu/xorg/x11-extra-modules/nvidia_drv.so and/ or /usr/lib/i386-linux-gnu/xorg/x11-extra-modules/nvidia_drv.so still exist, remove them too.

If you have previously installed nvidia from nvidia.com, follow these If you've installed the driver from nvidia.com instructions. Finally, reinstall the nvidia drivers:

sudo apt-get install nvidia-current

Reboot and everything should be working again.


Your laptop has a Nvidia GT 540M card which is most often an Optimus chip. However, it seems that your manufacturer has disabled the Intel iGPU and thereby disabled Optimus. This was detected by Bumblebee and therefore it refused to start at all. However, since this is not checked at installation of bumblebee and the nvidia driver is disabled, your desktop resolution got screwed up because it falls back to the VESA driver. This situation can be remedied by removing bumblebee:

sudo apt-get purge bumblebee bumblebee-nvidia

As a note to other readers, for machines that do not have the iGPU disabled there might be a BIOS option controlling whether the Intel or Nvidia GPU should be used by default.

share|improve this answer
    
THank you. It's solve my problem ! I have done a lots of things for solve my problem. I hope i don't broke anything :) –  Eray Aug 26 '12 at 23:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.