Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to use the built-in bluetooth device of my Lenovo Thinkpad E320. It seems to be hard blocked, but i can't find any possibility to unblock it.

rfkill list returns:

0: tpacpi_bluetooth_sw: Bluetooth   
Soft blocked: yes   
Hard blocked:yes

cat /proc/acpi/ibm/bluetooth returns:

status:     disabled
commands:   enable, disable

I tried to enable it by:

  • Pressing Fn+F9 (Radio controll)
  • echo enable | tee /proc/acpi/ibm/bluetooth
  • rfkill unblock bluetooth
  • Trough the BIOS. But it's not mentioned at all

None of the actions influenced the ouputs above.

share|improve this question
I believe you've left off the quotes around enable in echo enable | tee /proc/acpi/ibm/bluetooth. It should be echo 'enable' | sudo tee /proc/acpi/ibm/bluetooth IIRC, – hexafraction Aug 26 '12 at 19:55
Still no success... (with quotes) – Non Aug 26 '12 at 20:31
Some people activated bluetooth in a dual booted windows. After a reboot it worked in linux too. – Non Aug 26 '12 at 20:42
I have the same issues and can temporarily get it working disabling the bios settings related to Bluetooth, restarting and then re-enabling them again. However unfortunately this reverts back as soon as I suspend the laptop and then I have to repeat the whole process over again. Not really what I'd expect from an Ubuntu certified laptop. :-/ – Gerry Jan 3 '14 at 15:28

after 5-10 bios resets to re-enable bluetooth during the last two years I decided to investigate this issue again. looks like there is a bluetooth switch emulation in the thinkpad_acpi module. turn this on via module options et voila -> working bluetooth!

echo options thinkpad_acpi dbg_bluetoothemul=1 bluetooth_state=1 | sudo tee -a /etc/modprobe.d/thinkpad_acpi.conf

reboot && block/unblock bluetooth as needed:

rfkill unblock all
share|improve this answer

I was also facing the same problem before. I had the parallel installation of Windows. For working of blue-tooth, if I needed to start the blue-tooth option, I enable it with F9 function key of Windows. Then it starts working in Linux. If you have Windows installation there just check this case.

share|improve this answer

I resolved it by resetting BIOS settings. Be careful if you use EFI boot - it will erased and you will need to recover it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.