Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had to force shutdown my Ubuntu 12.04 64-bit, after which I restarted and tried to log in as a normal user, which was rejected several times. I then logged in as guest and tty to my regular account with use of my normal password, which succeeded. (So the password is still valid.)

How can I gain access again via the normal login procedure (welcome screen)?

Update:

When I tried to log on with my new password, it again was denied. When I deliberately tried to log on with a faulty password, an error message came back, saying:

Access denied - wrong password. 

I suppose, the first time the password was not rejected, but the procedure was aborted for some reason.


Some additional info after trying to find a solution: I am conviced it is a Compiz-issue. Why? before this happened, all sessions came to a grinding halt, regardless of being logged on in a 2D or 3d environment. I found a link saying that I should remove Compiz and proceed in a 2D environment, which initiall worked without a glitch, until my system went into a state of total obivium. Only after that, the above mentioned troubles appeared. In the meantime I have happened to find a thread with reference 17381, describing exactly what I have experienced. For now, I will try to cure this situation (later this week) and revert with the results, hopefully to close this post.

In the meantime I cordially thank you all, even if you didn't kill the problem; you gave me the inspiration to look further and find a possible cure.

Update2: After 15 hrs of trial-and-error I callled it quits (When I decided to tackle this problem, I've given myself 12 hrs, to avoid massive loss of time.) I decided to re-install Precise, since the "point 1" version has become availabe. Log-in is back to normal, as is the graphic environment. Response to mouse input is stil appalling, especially when I have a series of screens open as "children"of a "parent" screen. It still completely locks up. I have installed Enlightenment, Gnome classic, Gnome 3, Cinnamon and they all behave in a similar fashion.

FOR THOSE WHO NEED A WAY-OUT IN SITUATIONS OF THE LIKE: Open a terminal with [Ctrl+Alt+F2]. Type [sudo killall Firefox] (or whatever application you wish to terminate). Key in your password. Return to your graphical screen with [Ctrl+Alt+F7], and Bob's your uncle. Just re-open Firefox like nothing happened.

Next time you are stuck: [Ctrl+Alt+F2], upward arrow till you meet the command of your desire, [Ctrl+Alt+F7], etcetera. Hope this is of help. My next move will be to upgrade the kernel to 3.4 from the repositories for 12.10. However, since this entails a totally new situation, I will start a new thread on this site to avoid topic pollution

I will keep you posted. Still.

share|improve this question
add comment

1 Answer 1

Try resetting your account's password from the command prompt. If you are able to gain root access, just use CTRL-ALT-F2 to access the terminal and login as root. If you are unable to gain root access, reboot and select the recovery mode option in grub, then select the option to drop to the root shell prompt.

Once you have the root command prompt, you can change your users password with the following:

# passwd usr

Where usr is replaced with your account name. You should then be prompted to enter the new password for that account. You may want to try changing it to something else entirely, then changing it back. After that, reboot and try logging in properly again.

share|improve this answer
    
that sums it up nicely –  steabert Aug 27 '12 at 17:26
    
I have the same issue but this didn't work for me. I think I changed my display manager from gdm to lightgdm which seems to have broken something. –  Sridhar-Sarnobat Sep 16 '13 at 4:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.