Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an external USB 2.0 harddisk (Seagate 9SD2A2-500) that periodically "freezes" when files on the drive are not written to or read within approximately five minutes. The drive is formatted as ext4, and I am running Ubuntu 10.04 LTS 64-bit.

If I am editing a file that is stored on this drive, and I do not save the file every five minutes, an open application (such as gedit) will become unresponsive. I must wait for at least a minute before the external drive becomes responsive again and the file can be saved. I've also noticed this behavior when trying to access a file in Nautilus.

It appears that the drive is "falling asleep" and then "wakes up" after a certain time. What is happening here, and is it possible to change this behavior?

I have another USB 2.0 harddisk attached to the computer. The harddisk is formatted as FAT32, and does not show this behavior.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

This is a "feature" rather than a bug related to power management of your external hard drive unrelated to formatting. Things you could try to do:

Disable harddisk power management from your BIOS. Ask Seagate on how to disable power management on their external USB drives.

This is entirely not an Ubuntu issue.

share|improve this answer
    
Seagate has a Windows application that allows for harddisk power management to be turned off. Apparently this feature ships on many of the drives manufactured by this company. I downloaded the "FreeAgent" software from the Seagate website and ran it using my Windows OS partition. Although the drive is a "Seagate Expansion Portable Drive," the software did work to turn off power management. Thank you for your response; if I wouldn't have posted here and received help from you and Vincenzo, I might not have resolved this issue. –  Nicholas Kinar Dec 19 '10 at 1:51

I think it depends on hardware (controller) of external HDD. Possible issue: HDD suspending after 5(10) minutes. It could be also a specific management of USB controller in your computer system (USB inactivity time-out). Control in Power Management Preferences if 'Spin down hard disks when possible' is switched off.

Good luck, Vincenzo

share|improve this answer
    
I wish that I could mark both of these answers as the accepted one. I believe that this does depend on the hardware controller of the external HDD. You are right about the 'Spin down hard disks when possible' flag; this was set for when I was running on battery power (but not AC power), so I unchecked it. Thank you for your response. –  Nicholas Kinar Dec 19 '10 at 1:42
    
+1 for pointing to spin down flag –  Takkat Dec 19 '10 at 7:35
    
Dear Nicholas ! Thank you for your comments. The most important thing is that your problem has been solved quickly !!! :) –  Vincenzo Dec 19 '10 at 9:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.