Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

When I try to install VLC media player this pops up:

The following packages have unmet dependencies:

vlc: Depends: vlc-nox (= 2.0.3-0ubuntu0.12.04.1) but 2.0.3-0ubuntu0.12.04.1 is to be installed
     Depends: libavcodec-extra-53 (>= 4:0.8-1~) but 4:0.8.3ubuntu0.12.04.1 is to be installed
     Depends: libavutil-extra-51 (>= 4:0.8-1~) but 4:0.8.3ubuntu0.12.04.1 is to be installed
     Depends: libc6 (>= 2.15) but 2.15-0ubuntu10 is to be installed
     Depends: libfreetype6 (>= 2.2.1) but 2.4.8-1ubuntu2 is to be installed
     Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
     Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.1-0ubuntu4.2 is to be installed
     Depends: libqtgui4 (>= 4:4.7.0~beta1) but 4:4.8.1-0ubuntu4.2 is to be installed
     Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is to be installed
     Depends: libva-x11-1 (> 1.0.15~) but it is not going to be installed
     Depends: libva1 (> 1.0.15~) but it is not going to be installed
     Depends: libxcb-composite0 but it is not going to be installed
     Depends: libxcb-randr0 (>= 1.1) but it is not going to be installed
     Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed
     Depends: zlib1g (>= 1:1.2.3.3.dfsg) but 1:1.2.3.4.dfsg-3ubuntu4 is to be installed

Can someone please tell me what this means?

How can I get around it? (if possible)

P.S. I am also receiving similar pop ups when trying to install most programs.

I am using Ubuntu 12.04 64-bit.

Any help will be much appreciated.

share|improve this question

marked as duplicate by Seth, karel, Braiam, Eric Carvalho, Ask Feb 21 at 4:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2  
Did you happen to use a PPA for VLC at all? This lead to a problem for me. –  Ryan McClure Aug 26 '12 at 14:21
    
How did you install it ? eg terminal, software center or with a .deb –  mark kirby Aug 26 '12 at 15:33
1  
Please post your sources.list. –  terdon Aug 26 '12 at 16:40
    
Are you able to reproduce this? –  Braiam Feb 20 at 17:39
add comment

1 Answer 1

You need to install unmet dependencies.

You need to install:

libavcodec53 libavcodec-extra-53 libavformat53 to install this libavcodec53, libgsm1 libschroedinger-1.0-0, libavcodec53, libavcodec-extra-53 libavformat53, gstreamer0.10-ffmpeg, gstreamer0.10-plugins-bad, ffmpeg

Run the following command:

sudo apt-get install libgsm1 libschroedinger-1.0-0 libavcodec53 \
    libavcodec-extra-53 libavformat53 gstreamer0.10-ffmpeg \
    gstreamer0.10-plugins-bad ffmpeg

If it says to install any unmet dependencies then install them first after finishing installing all those dependencies then you should be able to install vlc.

I hope it will help you

share|improve this answer
    
Dependencies are automatically resolved using apt-get or aptitude... –  gertvdijk Dec 30 '12 at 11:37
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.