Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My processor is Intel P6100 which is a Dual Core processor. When I do

cat /proc/cpuinfo

this is what get

varun@varun-K52F:~$ cat /proc/cpuinfo
processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 37
model name  : Intel(R) Pentium(R) CPU        P6100  @ 2.00GHz
stepping    : 5
microcode   : 0x2
cpu MHz     : 1999.000
cache size  : 3072 KB
physical id : 0
siblings    : 1
core id     : 0
cpu cores   : 1
apicid      : 0
initial apicid  : 0
fdiv_bug    : no
hlt_bug     : no
f00f_bug    : no
coma_bug    : no
fpu     : yes
fpu_exception   : yes
cpuid level : 11
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx rdtscp lm constant_tsc arch_perfmon pebs bts xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm pcid popcnt lahf_lm arat dtherm
bogomips    : 3990.07
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

Why does it show only 1 core?

EDIT: Output of

cat /proc/cpuinfo | grep -i processor | wc -l

is also

1

`

share|improve this question
    
Have you installed the 64 bit version, rather than the 32 bit version? –  arochester Aug 26 '12 at 11:48
    
32 bit version of Ubuntu 12.04 –  Schweinsteiger Aug 26 '12 at 11:49
    
@arochester :how does that affect Ubuntu detecting the number of cores? Could you please explain that? –  Schweinsteiger Aug 26 '12 at 11:54
    
The 32-bit version of Ubuntu detects less cores than 64-bit, however the limit is 8, not 1. Have you checked your BIOS configuration to ensure that the cores and hyperthreading are not disabled? Also, to ensure your motherboard supports multicore and HT? –  dobey Aug 26 '12 at 13:06
    
Yes my motherboard does support Multicore but not hyper threading. I changed Grub to load with nolapic and ASPM. could that be a reason why it detects only 1 core? –  Schweinsteiger Aug 26 '12 at 13:08

1 Answer 1

up vote 1 down vote accepted
  • The kernel option nolapic effectively disables the use of all but the first processor.
    • Instead of using nolapic, please try to specifically solve any issues you have, asking new questions if necessary :)
  • Additionally, to detect and use multiple cores on Ubuntu 12.04 32-bit, you need to be running the -generic-pae kernel. Please verify this with uname -r.
share|improve this answer
    
Yes, I'm using generic-pae. So I guess, I would have remove nolapic to use both of my processors. –  Schweinsteiger Aug 26 '12 at 17:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.