Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When writing with the stylus pen (in for example Xournal) the multitouch function is very annoying: When I place my writing hand on the display it produces random lines and figures.

So I would like to (temporary) deactivate (multi)touch completely, so that only the stylus pen is accepted for input.

Is there any command that does this?

share|improve this question

1 Answer 1

You can achieve this by writing a small script to toggle "device enabled" property of the multi-touch input device. You can then bind this script to one of the keys for easy access or just execute it using any other method you prefer.

First you need to get the device name using xinput utility. Open a Terminal and type xinput list.

:~$ xinput list
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E6 Pen stylus                   id=10    [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E6 Finger touch                 id=11    [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                       id=14    [slave  pointer  (2)]
⎜   ↳ Wacom ISDv4 E6 Pen eraser                   id=16    [slave  pointer  (2)] 
⎜   ↳ SynPS/2 Synaptics TouchPad                  id=13    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Sleep Button                                id=8    [slave  keyboard (3)]
    ↳ Integrated Camera                           id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=12    [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                      id=15    [slave  keyboard (3)]

As you can see in this case the name of multi touch device is Wacom ISDv4 E6 Finger touch and its id is 11. Yours may be different. You can use the id as well, but I prefer the name since adding/removing devices could cause the id of some of the devices to change. Here is an example script that could get you started. All this does is toggle between two commands -- one to enable the multitouch device and one to disable it.

#!/bin/bash
#!/bin/sh
# This script can be used to toggle enable state of wacom multitouch screen for
# Thinkpad Tablet Series. You may need to change the name of multitouch device 
# which can be found by running *xinput list* command

TOGGLE=$HOME/.multitouch_toggle

if [ ! -e $TOGGLE ]; then
    touch $TOGGLE
    xinput set-prop 'Wacom ISDv4 E6 Finger touch' 'Device Enabled' 0
else
    rm $TOGGLE
    xinput set-prop 'Wacom ISDv4 E6 Finger touch' 'Device Enabled' 1
fi

I hope this will help you get around the problem for now. If you need any help with customizing or running the script above feel free to ask.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.