Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After enabling NVIDIA drivers in Ubuntu 10.10, Ubuntu sets monitor refresh rate to 50 Hz. When I try to change it to 60 Hz, I get this error:

CVT Output

cvt 1280 800

1280x800 59.81 Hz (CVT 1.02MA) hsync: 49.70 kHz; pclk: 83.50 MHz
Modeline "1280x800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync

xrandr Error Message

xrandr --newmode "1280X800_60.00"   83.50  1280 1352 1480 1680  800 803 809 831 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist) 
Major opcode of failed request:  154 (RANDR)
Minor opcode of failed request:  16 (RRCreateMode)
Serial number of failed request:  19
Current serial number in output stream:  19
share|improve this question

The nvidia binary drivers do not support XRandR 1.2, and so the xrandr tool is very limited when working with the nvidia binary. You can pretty much only query the list of available modes and set one, not add new modes.

So the failure of the xrandr tool is entirely expected.

Secondly, the nvidia binary driver abuses the reported refresh rate to work around some pre-XRandR 1.2 limitations with dynamic mode switching and multi-head. The reported refresh rate for the default mode will always be 50Hz, regardless of what the monitor is actually being driven at.

If you disable dynamic twinview in xorg.conf then this restriction is removed, and nvidia will report the actual refresh rate.

Alternatively, you can use the nvidia-settings tool to manipulate resolutions/refresh rates, and this will display the right values.

share|improve this answer
Thank you, that partly solved my problem. Now xrandr shows 60 Hz for my monitor but tearing is still there... – Mustafa Sami Altas Dec 21 '10 at 10:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.