Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to run a exe file that is located on my Vista partition, when I browse to the file and try to change the file to run as executable the tick box unticks itself right after i tick it, i tried running gksu nautilus but it does the same thing

share|improve this question
add comment

4 Answers

up vote 19 down vote accepted

This is likely because the Vista partition is using the NTFS filesystem and it was mounted with an fmask that does not permit setting execute permissions on files.

To fix this you need to manually mount the partition.

Details can be found on this post.


Here are the steps you need to take:

  1. Determine the drive's corresponding device by opening a terminal and typing: df
  2. The column on the far left is the device, and the column on the far right is the path for the drive. Find the device for the Vista partition.
  3. Unmount the Windows partition. (Click the eject button alt text that's next to it in Nautilus)
  4. Open a terminal
  5. Type the following:

    sudo mkdir /media/vista
    sudo mount -t ntfs -o fmask=0022,dmask=0000,uid=1000,gid=1000 \
        <DRIVE> /media/vista
    

    Replace <DRIVE> with your drive's device.

share|improve this answer
1  
ive never had this problem before doing the same thing though, and that post is WAY too technical for me lol –  Zabadda Dec 18 '10 at 18:43
    
@Zabadda: I added more clear instructions. Does that help? –  Nathan Osman Dec 18 '10 at 18:56
    
ok df gives me this paste.ubuntu.com/545368 –  Zabadda Dec 18 '10 at 19:32
    
@Zabadda: Assuming you had it mounted at that point, your Vista device is /dev/sda1. –  Nathan Osman Dec 18 '10 at 19:37
    
so is this what i need? sudo mount -t ntfs -o fmask=0022,dmask=0000,uid=1000,gid=1000 /dev/sda1/media/vista –  Zabadda Dec 18 '10 at 19:44
show 7 more comments

when using 10.04 running wine's .exes from a windows terminal worked alright, but now on 10.10 it just doesn't. I think it is a new security feature. Instead of running it from a windows partition transfer the files to your ubuntu filesystem, and run it from there. Works for me.

share|improve this answer
add comment

One other workaround is to enable the Wine PPA, since it disables the execute bit checking that the normal Ubuntu packages do.

share|improve this answer
add comment

I solved the problem through this link.

http://www.sinarpelangi.com/how-to-set-executable-permission-at-ntfs-partition-on-linux/

share|improve this answer
2  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  jokerdino Aug 23 '12 at 5:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.