Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I just installed ubuntu today with WUBI. After installing, the first time I tried to boot it, it gave me a screen with this grub prompt:

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

GRUB>

I tried repeatedly to reboot, and no luck. What it wrong?

Thanks, JT

share|improve this question

marked as duplicate by Eliah Kagan, vasa1, Mik, Gilles, Chris Wilson Mar 18 '13 at 13:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
You need to run chkdsk and then look for the root.disk. ubuntu-with-wubi.blogspot.ca/2011/08/missing-rootdisk.html –  bcbc Aug 26 '12 at 12:36
    
I am doing something similar HERE!!! askubuntu.com/questions/366001/ubuntu-13-10-grub-2-0 –  toobsco42 Oct 26 '13 at 5:23

3 Answers 3

Follow the steps below one by one.

  1. boot from the Ubuntu Live cd/usb and select "try ubuntu".
  2. when the desktop is loaded, download the boot script. It contains script and a changelog file.
  3. now cd to directory of the extracted zip file.
  4. chmode +x boot_info_script.sh 5.sudo bash boot_info_script.sh The above steps must get you through.
share|improve this answer
    
How is this an answer? It's just asking to use to the boot_info_script to provide a troubleshooting log! –  izx Aug 26 '12 at 2:53
    
After performing the above 4 steps It worked for me, you can save the log file which is returned after the last step for diagnosing if the problem still remains intact. –  droidlabour Aug 26 '12 at 8:36

Try the steps provided here.

Despite the question asked there was a little different, if it doesn't work for you it should at least provide more info about your specific problem.

share|improve this answer

When the machine first froze, did you just switch it off, because you did not know how to regain control? If so, you have probably corrupted the file system and that has apparently prevented grub finding its files.

The first thing to try is to boot from the livecd, open a terminal, type su to become root, enter the root password (root for a standard livecd) when prompted, and then run fsck -fy /dev/sdax where ax is the letter and number of your pclos partitions. To find out which they are you can use fdisk -l (that's a lower-case 'L'). You don't need to (and can't, in fact) fsck the swap, but the / and /home or whatever you have need to be done. They must be unmounted, but should be by default with the livecd. If not, use umount /dev/sdax to unmount them.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.