Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After spending hours trying to get my wired Comcast Internet to work on Ubuntu, I thought I had finally got it to work when I discovered that I needed to set it as a static IP by setting the Ipv4 as manual and filling in the required information (I was able to see the up and down arrows afterwards). It only took a few minutes to realize I still had more work to do. Firefox pages load indefinitely and downloads from the software center stay in waiting mode. My question is, what did I do wrong?

My stats and such:

Mac is BC:AE:C5:99:FD:14

(For cloned I just put the same). I don't think there is any 802.1x security so I left it unchecked. IP is 24.23.188.52.
Subnet mask is 255.255.255.0.
Gateway is 192.168.1.1.
Dns servers are 75.75.75.75, 75.75.76.76, 192.168.1.1, 208.67.222.222.
Search domains I didn't know any so I put google.com (that's probably the issue but I don't know).
Also Ipv6 I left as Automatic.
My pc is dual booted with Windows 7 64bit and Ubuntu 12.04 64bit.

EDIT: Ok, I tried NlightNfotis's directions, here is what happened:

Pinging www.askubuntu.com returned tradping: unknown host www.askubuntu.com Doing traceroute returned the program 'traceroute' can be installed in the following packages: inetutils-traceroute traceroute It then told me I could install it with sudo apt-get, and I tried that but it "could not find the package"

Adding 8.8.8.8 to DNS did nothing, unfortunately. 8.8.4.4 does nothing also.

I am very new to Linux and Ubuntu, by the way.

Setting the connection to DHCP doesn't disconnect it, but the internet still refuses to load anything.

Still have nothing, netstat -nr doesnt show any items under any category.

Here is a random pic with data, maybe it'll help. http://www.mediafire.com/view/?zk2yjn7khfocf94# (IPv4 from when its on manual)

Any and all help is appreciated.

share|improve this question
    
Now that you have set the DHCP settings to automatic, let's try to restart the network to have the DHCP server assign it an IP address. Try this: sudo /etc/init.d/networking restart –  NlightNFotis Aug 25 '12 at 20:23
    
Ok. Btw I tried to post pics but it wouldn't let me. –  user85197 Aug 25 '12 at 20:34
    
Hmm. It said something, but it made not very much sense. Pic: mediafire.com/view/?yho3660f5q6mcrc# also maybe this will help? mediafire.com/view/?gv0dbnbgo4vlgrs# its from when I entered ifconfig into Terminal. –  user85197 Aug 25 '12 at 20:51
    
Great! Check to see now if you have network connectivity. –  NlightNFotis Aug 25 '12 at 20:53
    
I wonder why it gives you this ip: 24.23.188.52 if the gateway is at 192.168.1.1. It doesn't make any sense. Normally the DHCP server should assign something like 192.168.1.3. –  NlightNFotis Aug 25 '12 at 20:55

2 Answers 2

Try to set your DNS server to 8.8.8.8 and 8.8.4.4 (Google's public dns servers) and see if this shows any changes.

Also try to change the network settings from manual mode to Automatic (DHCP). I suggest doing so if your network router supports a DHCP server, which automatically assigns IP addresses to hosts on the same network: enter image description here

share|improve this answer
    
OK I'll try that, will post results in a few minutes. –  user85197 Aug 25 '12 at 19:04
    
I had it on DHCP before, it never worked for me. Isn't that for a dynamic Ip? I'm pretty sure mine is static. –  user85197 Aug 25 '12 at 19:40
    
There is a difference between Public network and internal network IPs. You may have a static public network IP, and still have dynamic internal IPs. –  NlightNFotis Aug 25 '12 at 19:41
    
Oh. I'll try that then. –  user85197 Aug 25 '12 at 19:44

In Edit Connections make sure the Connection Name is Auto(eth0) ie ethzero-MTU is set to automatic-IP v 4 settings are Method: Automatic(DHCP), both boxes are ticked for 1. Require IP4 addressingfor this connection to complete, and 2. Available to all users, In IP v 6 settings, make sure Method: is set to Ignore, and tick the box for Available to all users

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.