Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to start mongod but I get

$ mongod
mongod --help for help and startup options
mongod: symbol lookup error: mongod: undefined symbol: _ZN7pcrecpp2RE4InitEPKcPKNS_10RE_OptionsE

Searching on google it seems to be related with libpcre; I tried to install last versions of libpcre3 and libpcre++ but it doesn't work.

MongoDB shell's version (and mongodb-server's version) is 2.0.4. Ubuntu's version is 12.04. libpcre3's version is 8.12-4. libpcre++0's version is 0.9.5-5.1.


share|improve this question
You can also use the 10gen-provided repository and packages: – Ernest Apr 29 '13 at 19:33
up vote 2 down vote accepted

We had the same issue, and we're not sure what caused it.

We tried to reinstall via apt-get, after purging and such, to no avail.

We downloaded the 64-bit precompiled version from the MongoDB website and tried running mongod from that package, and it started up fine. You'll probably want to stick with the 2.0.4 version - we used this file.

We moved the files in bin/ to /usr/bin, and mongod was starting correctly again.

This isn't a nice fix, but it does work.

share|improve this answer

I had this exact problem recently on Amazon Linux, and the solution seems likely to be the same here as it was for me. The issue was that I was using the default operating system repositories (which had and have out-of-date versions of Mongo packages) instead of using 10gen's own repositories. 10gen's version of the package does not suffer from this bug.

After removing the Ubuntu repo version of MongoDB, here's how you can install up-to-date packages.

Import 10gen's gpg key:

sudo apt-key adv --keyserver --recv 7F0CEB10

Create a /etc/apt/sources.list.d/10gen.list file and include the following line for the 10gen repository.

echo 'deb dist 10gen' | sudo tee /etc/apt/sources.list.d/10gen.list

Run sudo apt-get update and then sudo apt-get install mongodb-10gen

Instructions were pulled from this page:

Anyone running into this issue on something in the RHEL family can find instructions here:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.