Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed axel and set it to get my firefox downloads through flashgot. It works but the Axel window is not visible - so cannot know when the download starts and ends, its speed etc.

I have recently installed Lubuntu Precise. Before I was using the same but the main installation was Xubuntu and did not have this problem.

share|improve this question
are you using any script? – green Aug 25 '12 at 13:52
It's working fine for me. – green Aug 25 '12 at 13:58
no scripts installed in firefox. after reinstalling axel, the same problem – cipricus Aug 25 '12 at 14:01
I'll try on Lubuntu and get back to you. – green Aug 25 '12 at 18:23
added the (tested) answer. – green Aug 26 '12 at 7:52
up vote 1 down vote accepted

When you initiate the download the status is not shown in the terminal installed in lubuntu, but on 'xterm'. All you have to do is to install xterm:

sudo apt-get install xterm

'xterm' comes installed with Ubuntu and Xubuntu, that's why it worked fine when you had Xubuntu with lubuntu-desktop installed.

share|improve this answer
i had lxterm, xfce4-term and gnome terminal installed, i didn't imagine something else was missing, but after installing xterm it is ok – cipricus Aug 27 '12 at 9:47

Is a window created with other console downloaders? (wget, aria2).

start any long download and run in terminal ps -C xterm,axel ww.Also you can try to run xterm from terminal xterm. Try the following variants:

  1. 'Alt+Tab' to take out the hidden window. Sometimes it helps. But I don't know if this combo works in lubuntu.
  2. Write down a command line for axel manually in the flashgot options.
  3. Reinstall flashgot.
share|improve this answer
no window with wget either. ps -C xterm,axel ww gives just ` PID TTY STAT TIME COMMAND`. alt-tab is real in lubuntu but axel is not there. – cipricus Aug 25 '12 at 21:23
could not find a command line that worked, and that was not the question anyway. reinstalling flashgot did not helped – cipricus Aug 25 '12 at 21:32
downgrading flashgot version did not help – cipricus Aug 25 '12 at 21:37
I meant any flashgot-axel download. What does the command xterm give? Possibly you don't have the xterm program or it is broken. – seeline Aug 26 '12 at 5:11
yes, that was it. but the other answer is more up to the point so i'll make that the one. upvote and thnk you – cipricus Aug 27 '12 at 9:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.