Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have software RAID in my system, and I would REALLY like it NOT to automatically start at system boot.

Ubuntu system is installed on a partition not on a RAID (no need whatsoever to start raid for booting system)

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.1 LTS
Release:        12.04
Codename:       precise

uname -a
Linux coruscant 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I did try to:

  • Manually prevent anything (module/script) MD/RAID to be loaded in initramfs image

  • Blacklist raid module

  • Passing to the kernel raid=noautodetect

How can I do this?

share|improve this question

1 Answer 1

When booting to ubuntu live CD, you will see a picture of a man and a keyboard. Press any key to get in the menu. You will see a menu named "other options" and then you will see an entry for the raid. Good luck!

share|improve this answer
    
and if i look hard enough i can also see Elvis ? ... right, can you please don't make fun on me ? ... even if i believe what you say, you really didn't give enough information to find that "magic options", also that thing MUST pe possible after system is installed, ... and this is a real problem for me be cause i need to set up raid in a certain way and i REALLY don't want system to start it and mark some drives as faulty and then try to "fix" them –  THESorcerer Aug 26 '12 at 22:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.