Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, I installed the software sources app on my 12.04 LTS but it doesn't show on the installed applications (applications lens). It shows on /usr/share/applications. What needs to be done so that the Software Sources icon appear on the application lens? Thanks.

[Desktop Entry]
Name=Software Sources
GenericName=Software Sources
Comment=Configure the sources for installable software and updates
Exec=software-properties-gtk
Icon=software-properties
Terminal=false
NoDisplay=true
X-MultipleArgs=false
Type=Application
Categories=GNOME;GTK;Settings;X-GNOME-SystemSettings;
MimeType=text/x-apt-sources-list;
X-KDE-SubstituteUID=true
X-Ubuntu-Gettext-Domain=software-properties
share|improve this question
    
Can you please post the contents of the corresponding .desktop file located at /usr/share/applications ? –  hakermania Aug 25 '12 at 13:10
    
[Desktop Entry] Name=Software Sources GenericName=Software Sources Comment=Configure the sources for installable software and updates Exec=software-properties-gtk Icon=software-properties Terminal=false NoDisplay=true X-MultipleArgs=false Type=Application Categories=GNOME;GTK;Settings;X-GNOME-SystemSettings; MimeType=text/x-apt-sources-list; X-KDE-SubstituteUID=true X-Ubuntu-Gettext-Domain=software-properties –  williepabon Aug 25 '12 at 23:26
    
Edit your answer, do not post it as comment. –  hakermania Aug 25 '12 at 23:27
    
hakermania: I just supplied the information you requested above. –  williepabon Aug 26 '12 at 0:15
add comment

1 Answer 1

up vote 2 down vote accepted

As explained here: http://standards.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html#key-nodisplay (NoDisplay means "this application exists, but don't display it in the menus") the NoDisplay field is causing this desktop shortcut not to show up in menus.

This, of course, was done deliberately by the developers of the application. However, if you wish to see this application in menus, just completely remove the NoDiplay field:

[Desktop Entry]
Name=Software Sources
GenericName=Software Sources
Comment=Configure the sources for installable software and updates
Exec=software-properties-gtk
Icon=software-properties
Terminal=false
X-MultipleArgs=false
Type=Application
Categories=GNOME;GTK;Settings;X-GNOME-SystemSettings;
MimeType=text/x-apt-sources-list;
X-KDE-SubstituteUID=true
X-Ubuntu-Gettext-Domain=software-properties
share|improve this answer
    
Thanks @hakermania. –  williepabon Aug 26 '12 at 20:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.