Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After updating 12.04, my HDD partitions and USB storage devices was removed from the devices list on Nautilus Sidebar, only the "floppy0" is there.

Screenshot Screenshot

I can see all of them with Disk Utility. I can mount them and add them to computer list on Nautilus (not to device list).

I can't see any device in /media, only "floppy", "floppy0" and "cdrom" folders.


fstab file:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass> proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda3 during installation UUID=ec9a8bbb-4cf0-4599-bf0e-85f7e3de6302 /               ext4   
errors=remount-ro 0       1
# swap was on /dev/sda6 during installation UUID=88002a18-0f7f-4e7a-87b7-ef8e9f6388c8 none            swap    sw  
0       0 /dev/fd0        /media/floppy0  auto   
rw,user,noauto,exec,utf8 0       0
share|improve this question
    
Can you try starting the "Disk Manager" program and post a screenshot of it? –  carestad Oct 23 '12 at 18:22

3 Answers 3

You can mount your partitions automatically on startup.

A very good tutorial on Ubuntu wiki on how to achieve it is given here.

You can also edit your /etc/fstab file, however it is more complex and generally not recommended if you've less experience.

/etc/fstab contains information of where your partitions and storage devices should be mounted and how.

The Ubuntu wiki also explains how you can edit the fstab file: here.

Additional References: http://www.tuxfiles.org/linuxhelp/fstab.html


The program that causes the nautilus to show the devices is gvfs-gdu-volume.

Check if it's running:

sudo ps -e | grep gvfs-gdu-volume

I got the following output:

1983 ?        00:00:00 gvfs-gdu-volume

If not, reinstall the package gvfs:

sudo apt-get install --reinstall gvfs
share|improve this answer
    
İt isn't my questions answer. I don't want to make an automount. I want to solve this problem img99.imageshack.us/img99/2739/ekrangrnts2012082516541.png where is my devices? Before uptade, there is. –  bzn7 Aug 25 '12 at 14:26
    
check the update –  green7 Aug 25 '12 at 17:56
    
I got "1503 ? 00:00:00 gvfs-gdu-volume" and didn't solved any problem. Than I reinstalled gvfs and that didn't solve anything too. (I rebooted system after reinstall) –  bzn7 Aug 25 '12 at 18:54
    
post the content of your /etc/fstab file. –  green7 Aug 25 '12 at 19:12
    
What about nautilus permisions? I have got an error for "sudo nautilus" once, but now this error isn't seen. When I switched my system language and make logout, login; problem is solving but rebooting is making problem again.. –  bzn7 Aug 25 '12 at 21:15

remove:

0 0 /dev/fd0 /media/floppy0 auto

from fstab worked for me.

share|improve this answer

I am sure you are running nautilus in root or else you logged in as root. open terminal and check whether root@"name" is written that means you are logged in as root

share|improve this answer
    
Logging in as root on a graphical login screen does not work. Theoretically this could be enabled but it's not as simple as setting a password for root and in any case someone who'd enable full graphical root sessions (a bad idea!) would almost certainly know they did so. On the other hand, it's much easier (and sometimes appropriate) to run Nautilus as root (with gksudo nautilus or sudo -H nautilus or the like). It's possible that devices mounted by one user wouldn't be shown by Nautilus running as another... but the prompt in a new terminal won't show what user's running Nautilus! –  Eliah Kagan Mar 24 at 22:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.