Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Trust graphics tablet. Today I realized how to make GIMP use the tablet's sensitivity features: by going to Edit > Preferences > Input Devices > Configure Extended Input Devices, and there change the settings for the tablet. This works fine, until I close GIMP and reopen it. Then no input device is able to do anything and I need to go through the menus again to enable the tablet.

What happens is that there are two entries for extended input devices to the tablet: one for the tablet's stylus, and one for its mouse (not my PS/2 moues, but rather a mouse that arrived packed with the tablet and that is used by it). Whenever I change the settings for the stylus entry, it works, but when I quit GIMP and reenter, it somehow transfers the settings I used for the stylus to the second entry: that of the mouse.

It's probably because GIMP recognizes the two input devices with the same name (I can see two "UC-LOGIC Tablet WP8060U" entries in the settings dialog) and somehow it attributes the settings I made to the mouse before it does to the stylus. Maybe if I change the name of one input device it will work properly? How do I do that? And if that doesn't work, what else can I try?

EDIT: After reading a little, I tried tinkering with the options found in /usr/share/X11/xorg.conf.d, but I only managed to make The X server ignore the stylus instance of the tablet and not the mouse instance. I don't understand how that's possible, as I went through everything in the driver that activates the tablet and disabled it. Any other ideas?

share|improve this question

There is a "Save input device settings on exit" right on the "Input Devices" tab in the Preferences dialog. Use it :)

share|improve this answer
Yes, it was enabled, but the problem was that it saved the settings on the wrong input device, i.e., the mouse. – Amir Adar Sep 21 '12 at 13:48

You might try something like

Section "InputClass"
     MatchUSBID "5543:0005"
     MatchDevicePath "/dev/input/mouse*"
     Option "Ignore" "on"

Which should ignore just the mouse interface, you can replace the USBID with the correct one, but I believe that is the correct one for the WP8060. Hopefully that helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.