Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How would I go about upgrading MySQL to version 5.5 on Ubuntu Server 9.10?

Would I be better off waiting for it to be an easy $ sudo apt-get install mysql-server job?

I'm also unsure as to which download I would need to get from here.

share|improve this question
1  
Before you do anything, this is what i have been working on for the past 4 days. trying to have mysql 5.5.8 in ubuntu 10.10 in my case. I have used alien to change a rpm package to a deb package and install (FAILED). I have downloaded the binary ones with the intention to use them as the default ones (FAILED). And as you can see from that LONG list of packages, Oracle did NOT care much about debian distros. They made many RPM ones. MANY. But not a single DEB package. There is a group here ubuntuforums.org/showthread.php?p=10245558 that is talking about the same problem. Lack of Oracle. –  Luis Alvarado Dec 18 '10 at 15:13
    
Appreciate the heads up @Cyrex –  bcmcfc Dec 18 '10 at 15:23

7 Answers 7

up vote 11 down vote accepted

What's New in MySQL 5.5

Here are some recent improvements to the speed, scalability, and user-friendliness of the MySQL database and the InnoDB storage engine.

A step by step guide to upgrading to MySQL 5.5

share|improve this answer
    
Am going to test this and let the rest know. –  Luis Alvarado Dec 18 '10 at 20:02
    
Thanks for mentioning my post,. I hope it helps,. –  ovais.tariq Dec 20 '10 at 19:12
    
It helped but i needed to change several things before it worked correctly. Now that i have the time i might make a small script that will do everything in one run. But i have to admit, it worked after several tries against MANY other tries i had done before your awesome post. –  Luis Alvarado Dec 26 '10 at 6:20
1  
At last here is what i have after installing it 19 times in 5 different servers ranging from ubuntu 8.04 to ubuntu 10.04. the following are the EDITs that are needed to have it without errors to anybody with mysql 5.1 already installed and want to go to 5.5.8 or 5.5.9: + Before starting the mysqld server be sure that all the files in the /usr/local/mysql/bin folder have the executable permission. –  Luis Alvarado Mar 6 '11 at 0:36
1  
+ When doing the restore of the mysql.sql backup the correct folder is /root/mysql-5.1-dump/ and not /root/mysql-5.1-backup/dump/ + In the part about starting mysql with "mysqld --skip-grant-tables --user=mysql" you first need to mention that the /etc/my.cnf needs to be put in the BOTTOM of the file + After mysql_upgrade you might NEED to kill the mysqld process before starting it with the /etc/init.d/mysql –  Luis Alvarado Mar 6 '11 at 0:38

There is a painless installer for mysql 5.5 on debian at dotdeb.org. They have instructions about how to get their repository listed with aptitude, here: http://www.dotdeb.org/instructions/ Once that was done, I used Synaptic to upgrade mysql-server to version 5.5 . It worked without a hitch.

share|improve this answer

There ist a brand-new ppa (personal package archive) repository which includes - beneath other things - mysql5.5 for natty and oneiric:

https://launchpad.net/~nathan-renniewaldock/+archive/ppa

It may be added to your system using this commands:

sudo add-apt-repository ppa:nathan-renniewaldock/ppa
sudo apt-get update
share|improve this answer

The process for upgrading from 5.1 (if you've built a LAMP server) to 5.5 are described here If you are interested in just installing a vanilla MySQL server, then build a clean install of your server and follow those directions at the page I referenced which do not involve a previously installed MySQL instance.

If you want to use phpMyAdmin, you will need to build a LAMP server (as described here and then follow all of the instructions for upgrading contained in the previous link. This will allow you to use the apt-get for all of the necessary packages for phpMyAdmin and then switch out the MySQL version.

share|improve this answer

I have sucessfully installed MySQL-5.5.15 into Natty (Ubuntu 11.04) with alien from official binary RPMs.

Install alien and libaio1 (used from MySQL-5.5)

apt-get install alien libaio1

Fetch binary RPMs from MySQL downloads

$ wget -i -
ftp://MIRROR_SERVER/pub/mysql/Downloads/MySQL-5.5/MySQL-client-5.5.15-1.linux2.6.x86_64.rpm
ftp://MIRROR_SERVER/pub/mysql/Downloads/MySQL-5.5/MySQL-devel-5.5.15-1.linux2.6.x86_64.rpm
ftp://MIRROR_SERVER/pub/mysql/Downloads/MySQL-5.5/MySQL-server-5.5.15-1.linux2.6.x86_64.rpm
ftp://MIRROR_SERVER/pub/mysql/Downloads/MySQL-5.5/MySQL-shared-5.5.15-1.linux2.6.x86_64.rpm
^D

Convert them!

fakeroot alien MySQL*.rpm

...and, install them.

sudo dpkg -i mysql*.deb

Add mysql user

useradd -r mysql

Initialize data directory

mysql_install_db --datadir=/var/lib/mysql --rpm --skip-name-resolve --user=mysql

Set other necessary paths

mkdir /var/lib/mysqld
chown mysql /var/lib/mysqld/

mkdir /var/log/mysql
chown mysql /var/log/mysql

Start DB

service mysql start

Change the root password

/usr/bin/mysqladmin -u root password 'your_password'
share|improve this answer

A good option might be to wait for a version from dotdeb.org. Once it's available in Debian unstable/experimental, there will be packages available there.

http://www.dotdeb.org/tag/mysql/

share|improve this answer
    
I did not know about dotdeb before your post. thank you. –  Luis Alvarado Dec 26 '10 at 6:20

This doesn't solve your problem but here's the wishlist bug for packaging MySQL 5.5.

share|improve this answer
2  
FYI, I just assigned that bug to myself and am watching the first attempt build right now.. :-D –  SpamapS Dec 21 '10 at 19:14
    
As an update.. 5.5.17 has landed in Precise Pangolin Alpha1 (the next LTS, 12.04)... the source package should build just fine for earlier releases, and can be found here launchpad.net/ubuntu/+source/mysql-5.5 –  SpamapS Dec 2 '11 at 0:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.