Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Crashplan and it is constantly running in the background and making backups every 15 minutes. It caused some problems with the backup target folders, so I want it to be inactive while I am making changes to these folders.

I started the application itself, but could not find some kind of "Pause" button. So I decided to just stop its process. I first tried the lazy way - the system monitor in the Gnome panel has a "Processes" tab - but didn't find it listed there. Then I did a sudo ps -A and read through the whole list.

I don't recognize everything on the list (many process names are self-explaining, like evolution-alarm, but I don't recognize others like phy0) but there was nothing which sounded even remotely like crashplan. But I know that there must have been a process belonging to Crashplan running at this time, because the main Crashplan window was open when I ran the command.

Do you have any advice how to stop this thing from running? The best solution would involve temporary preventing it from loading on boot too, since I may need to reboot while doing the maintenance there.

share|improve this question
    
A process that runs repeatedly but doesn't appear in the process list may well be using cron/anacron to schedule itself. Look in /etc/cron* for clues. (I don't know anything about Crashplan specifically). –  msw Dec 18 '10 at 15:58

1 Answer 1

up vote 5 down vote accepted

From the Crashplan website it looks like it should be starting a process from /etc/init.d at bootup. I would look in /etc/init.d to see if there are any startup scripts that look like they are for Crashplan. You can easily temporarily prevent a startup script from running at boot time by running:

sudo update-rc.d script-name disable

Where script-name is the name of the script you see in /etc/init.d that you want to disable. It can be re-enabled later by running:

sudo update-rc.d script-name enable

This will put things back the way they were before you disabled the script.

Also, the website says you can stop crashplan temporarily by running:

sudo /usr/local/crashplan/bin/CrashPlanEngine stop

The path is dependent on where you installed crashplan and will probably only stop the currently running process.

One last thing. I find that ps -ax provides more information than ps -A and can be useful when trying to find a running process, especially when the output is piped to grep. If I were looking for a process associated with crashplan I would try a command like this:

ps -ax | grep Crash

I hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.