Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Powertop from the Ubuntu Software Center and just realized that a new version is available. However this new version is not yet available in the Ubuntu Software Center. How do I then upgrade to the new version?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Powertop 2.1, based on the source from the Ubuntu 12.10 version, is available in my bleeding-edge PPA.

To add the PPA and install Powertop 2.1, please open a terminal with Ctrl+Alt+T and type/paste these lines (one at a time):

sudo apt-add-repository ppa:izx/bleeding
sudo apt-get update
sudo apt-get install powertop

Note: If you are unfamiliar with installing third-party software from PPAs, you may want to refer to these questions:

share|improve this answer
    
Dependency error: libnl-3-200>= 3.2.7 How do I update this lib? –  Mysterio Aug 25 '12 at 11:15
2  
@Mysterio; > Edit: The 2.1 package is now available in my ppa ppa:izx/bleeding; add, update and install! :) –  izx Aug 26 '12 at 18:28
    
Will it replace the older version or install the 2.1 version differently? –  Mysterio Aug 26 '12 at 21:37
1  
@Mysterio: it will replace it. –  izx Aug 26 '12 at 21:37
add comment

Traditionally major updates to applications are only backported to Ubuntu releases when they contain security fixes or unignorable benefits to users. You might want to track down powertop's Ubuntu maintainer to see what they feel.

Otherwise, you're left to get this from another source. In this case I think you should be fairly safe to look at the available builds here:

... And just snatch Quantal's version. It's dirty and you won't get upgrades for it but I don't think anybody is going to discover a remote exploit in Powertop so I think you're probably safe.

Other options including finding a PPA that hosts it or even downloading the source and building it yourself.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.