Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is a very strange problem. The only time the Wi-Fi works is when I have the wired connection connected. I have a Dell 6400/e1505 with the Broadcom BCM 4401-B0 internal NIC, and the Intel Pro/Wireless 3945ABG Wi-Fi adapter.

I was on 10.0.4 LTS before, and I remember having to screw around to get the Wi-Fi to work, but that was years ago, and now it's acting even stranger than it did back then.

If I boot up with the wire connected, the Wi-Fi starts up. If I boot up without the wire connected, the Wi-Fi won't start at all. If after booting with the wire connected, and the Wi-Fi starts up, I then disable the wireless, the wired connection works fine.

Without the wire connected, dmesg shows the iwl3945 driver loading and starting with no errors, and the wireless adapter activated. Running rfkill list shows no blocks, but there is no connection to my Wi-Fi.

Help! I am more confused than a chameleon in a bag of Skittles.

share|improve this question
    
What if you start with wired and wifi, and then remove the ethernet cable, and disable / re-enable wireless? –  bob Aug 25 '12 at 7:58
    
The problem is booting without the wire connected, which is what I want to be able to do. I need wifi! It's totally bogus that connecting the WIRE is the only way to get WIRELESS to work! –  Jerel Aug 25 '12 at 8:00
    
Oh, and btw, that does work fine. Doing what you said works fine. It does not, however, allow the wireless to work if I boot without the wire connected. –  Jerel Aug 25 '12 at 8:01
1  
Ok, I found the answer here. Turns out network-manager was not able to control the interface during startup. The solution is to edit /etc/network/interfaces and remove all the extra lines after "auto lo" and "iface lo inet loopback" and reboot. Now I just have to figure out how to make the wifi LED stop blinking 100% of the time. –  Jerel Aug 25 '12 at 19:01
1  
I also had to add a configuration file for my wireless adaptor to the modprobe.d directory. It had two lines: alias wlan0 iwl3945 and the second was options iwl3945 disable_hw_scan=1 –  Jerel Aug 25 '12 at 19:49

1 Answer 1

In 12.04, there is a iwl_legacy kernel module options that governs the blinking. To stop the blinking, add another file to /etc/modprobe.d/ with the following content - iwl_legacy=1.

step by step

  1. Run gksudo gedit /etc/moprobe.d/iwl_legacy.conf

  2. Copy/paste iwl_legacy into the file.

  3. Save and exit.

The wifi led shouldn't blink after a reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.