Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanted to format my usb, so I opened disk-utility to format. But the formatting process wasn't complete and gave me some error. Now my usb isn't detected; please help.

Please find the screen shot from dmesg:-

enter image description here


I upgraded to 12.04.1 yesterday, could that be a cause of the problem?

share|improve this question
2  
Try plugging Your USB drive in Other USB port of your system. –  atenz Aug 25 '12 at 6:58
1  
Shut down, start up, try again. If same problem, either port or drive died... –  izx Aug 25 '12 at 7:02
    
i've tried plugging the usb onto all the ports, its not being detected.Is there any logs I can check that will tell me what went wrong and how can I prevent the same in future? I have tried restarting the laptop. –  Ankit Aug 25 '12 at 7:08
add comment

1 Answer 1

up vote 1 down vote accepted

Try this - in terminal type:-

sudo killall udisks

then load gparted if you have it on your system - format to desired file system.

This command has helped with a lot of USB problems - it may help you.

good luck Mal

share|improve this answer
    
thanks, I managed to format the disk using gparted. I used the ext4 partition to format the disk. Now the disk is being detected. thanks again :) –  Ankit Aug 25 '12 at 7:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.