Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I get a program like glxgears to run on my computer? I've tried installing nVidia proprietary drivers (which reduce the resolution to 640x480) and bumblebee to no avail.

When I run optirun glxgears with bumblebee, bumblebee-nvidia, and nvidia-current installed it fails with:

[ 2654.015008] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 2654.015090] [ERROR]Aborting because fallback start is disabled.

I've read many other questions that seem to relate to my issue, but none of the answers have worked for me. It seems like one of the most common answers was that it is impossible to switch graphics with this kind of card, so in that case how should I go about disabling it and relying on the intel card?

I'm running Ubuntu 12.04 on an HP Pavilion dv6t-7000 with an nVidia GeForce GT 630M and am not a very experienced ubuntu user, so if I'm missing any critical information please point it out and I will happily provide it.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The solution lies in the bumblebee configure file. For anyone else with this problem, here's my process:

  1. Make sure that nvidia-current-updates and nvidia-settings-updates are uninstalled and nvidia-current and nvidia-settings are installed (sudo apt-get remove nvidia-current-updates nvidia-settings-updates sudo apt-get install nvidia-current nvidia-settings.

  2. Run sudo add-apt-repository ppa:bumblebee/stable, sudo apt-get update, and sudo apt-get install bumblebee bumblebee-nvidia.

  3. Change line 22 in /etc/bumblebee/bumblebee.conf to say "Driver=nvidia" and line 47 to say "KernelDriver=nvidia".

  4. Run sudo bumblebeed restart.

  5. Run optirun glxgears and admire the pretty graphics.

Line 22 in /etc/bumblebee/bumblebee.conf is originally "Driver=nvidia-current" which is not the name of the nvidia module.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.