Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Gmsh in 12.04 x64:

xxx@sjb-linux:/320/installslinux/gmsh$ sudo apt-get install gmsh
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gmsh : Depends: libmed1 (>= 3.0.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
xxx@sjb-linux:/320/installslinux/gmsh$ 

I have now tried all the advice I could get

sudo apt-get -f install
sudo apt-get clean

with no success, these commands report absolutely no problem.

I'll appreciate help.

share|improve this question
    
mention ubuntu version and System architecture like is it 32 bit or 64.. –  Sushantp606 Dec 2 '13 at 10:52
add comment

1 Answer

gmsh won't install because libmed1 won't install either. The problem is that there is a conflict with different versions of package libhdf5.

So in order to fix it

  • Open synaptic and searched for libhdf5
  • Then install libhdf5-openmpi-1.8.4, this will remove some of the libhdf5 packages and IIRC some octave-3.2 packages too.

After that I went on to install libmed1 and once that was done I was finally able to install gmsh.

So far I haven't had any further problems related to this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.